Modify

Opened 11 years ago

Closed 11 years ago

#3763 closed defect (fixed)

Keys lost when combining

Reported by: Nakor Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

In any area, create a new way without any tags.
Combine it with an existing way.
All tags are gone.

This is with 2300

Attachments (1)

Cleanup.osm.bz2 (672.0 KB) - added by Nakor 11 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by Gubaer

Resolution: worksforme
Status: newclosed

Can't reproduce.

comment:2 Changed 11 years ago by anonymous

There is definitely something going on here but I cannot reproduce it everty time. Most of the time closing and re-opening the model makes the issue go away.

comment:3 Changed 11 years ago by Nakor

Resolution: worksforme
Status: closedreopened

I could reproduce it. With the attached file try to combine ways 8,686,972 and 8,714,375

Changed 11 years ago by Nakor

Attachment: Cleanup.osm.bz2 added

comment:4 Changed 11 years ago by mjulius

I could not reproduce with your example and current latest r2542. Combining seems to keep all tags from way 8,686,972. The combined way gets id 8,714,375.

comment:5 Changed 11 years ago by anonymous

Well that is frustrating. I was able to reproduce it several time this morning. Now with a fresh start of JOSM it does not do it anymore.

I have encountered that issue quite a few time now. Is there some kind of tracking information I could activate to generate something useful to look into for debugging it?

comment:6 Changed 11 years ago by Nakor

If have seen this happen again. Is there a way to provide you with more info?

On a similar topic sometime, when you merge an existing node (with ID>0) and a new node (with id=0), the result is a new node (with id=0)

comment:7 Changed 11 years ago by Nakor

Happened again lately. Not always reproducible. How can I help tracking it down?

comment:8 Changed 11 years ago by bastiK

You can do data consistency check afterwards. And you should check, if it is a problem with the dialog, i.e. collapse and expand the properties dialog to see if the properties are there.

However, I doubt this helps much...

If you have rudimentary programming skills you could add some debugging output to MergeNodesAction.java to see at what point it misbehaves.

Either you can provide a way such that one of the developers can reproduce, or there might be little progress with this issue...

comment:9 Changed 11 years ago by jttt

Might be duplicate of #4406. Please let me know if it's still happening with version > r2996

comment:10 Changed 11 years ago by Nakor

Resolution: fixed
Status: reopenedclosed

I did not see it happen in a while so my guess is it has been fixed one way or the other.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.