Modify

Opened 11 years ago

Closed 11 years ago

#3550 closed enhancement (fixed)

make the width of the toggle dialog area resizable

Reported by: bastiK Owned by: bastiK
Priority: normal Milestone:
Component: Core Version: latest
Keywords: gui Cc:

Description

Not much to say about it.

Attachments (3)

split.patch (8.0 KB) - added by bastiK 11 years ago.
split-fix.patch (4.3 KB) - added by bastiK 11 years ago.
split-vertical.patch (96.8 KB) - added by bastiK 11 years ago.
lib included - should compile

Download all attachments as: .zip

Change History (15)

Changed 11 years ago by bastiK

Attachment: split.patch added

comment:1 Changed 11 years ago by bastiK

I can do the vertical splitting as well. (Change height of the dialogs)

For this, it would be required to include the Multisplitpane library. (LGPL v. 2 and later; jar is 45kB in size)

Please tell me, if you want that.

comment:2 Changed 11 years ago by stoecker

(In [2162]) see #3550 - patch by bastik - resize dialogs on right side

comment:3 Changed 11 years ago by stoecker

Owner: changed from team to bastiK
Status: newneedinfo
Summary: [PATCH] make the width of the toggle dialog area resizablemake the width of the toggle dialog area resizable

Applied, but stilll buggy. The three icons in the title line vanish in case the title text needs to be shortened.

Regarding vertical resizing - Can't we find an easier solution than including the library?

Changed 11 years ago by bastiK

Attachment: split-fix.patch added

comment:4 Changed 11 years ago by bastiK

Status: needinfonew
Summary: make the width of the toggle dialog area resizable[PATCH] make the width of the toggle dialog area resizable

Maybe it is possible without the library, but it wouldn't be easy for sure.

Explanation:

Desired behaviour:

  • All dividers stay fixed except the one that is dragged.

For MultiSplitPane it works like this by default.

The workaround (without the library) would be to nest multiple JSplitPane-s.

In this case, the construction acts rather strange and asymmetric (when the dividers are moved).

I played around with it to see if one can change the preferred sizes of the panels appropriately "on the fly" while the divider is dragged.
For what I can tell it doesn't work without considerable flickering.
Maybe it is somehow possible to avoid the flickering, but at large it is not worth the efford, when there is a library supporting exactly this. (It is written by a Sun employee, btw.)

It's a minor feature, so maybe we don't need it after all. :)

comment:5 Changed 11 years ago by stoecker

(In [2185]) see #3550 - fixed resizable side views - patch by bastiK

comment:6 Changed 11 years ago by stoecker

Status: newneedinfo
Summary: [PATCH] make the width of the toggle dialog area resizablemake the width of the toggle dialog area resizable

Can you provide a patch using the library. Do we need to include the library as binary or can we add it to the SVN as externals?

comment:7 Changed 11 years ago by stoecker

Ticket #2005 has been marked as a duplicate of this ticket.

comment:8 Changed 11 years ago by stoecker

Ticket #2071 has been marked as a duplicate of this ticket.

Changed 11 years ago by bastiK

Attachment: split-vertical.patch added

lib included - should compile

comment:9 Changed 11 years ago by bastiK

Status: needinfonew
Summary: make the width of the toggle dialog area resizable[PATCH] make the width of the toggle dialog area resizable

I haven't found any repository, so i think it is not possible.

Anyway, there are just two files - Maybe we can put them in the source tree directly.

comment:10 Changed 11 years ago by stoecker

(In [2224]) see #3550 - patch by bastiK - allow resizing right handside dialogs, updated i18n

comment:11 Changed 11 years ago by stoecker

Summary: [PATCH] make the width of the toggle dialog area resizablemake the width of the toggle dialog area resizable

I think some of the plugins must be updated as well, thus not closed yet.

comment:12 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

I don't expect any problems with plugins.

(-> Please reopen if something shows up.)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.