Modify

Opened 12 years ago

Closed 12 years ago

#3349 closed defect (fixed)

Last 3 few versions of josm report error on start. Neither measurement nor AgPifoJ plugins then work

Reported by: pert Owned by: team
Priority: normal Milestone:
Component: unspecified Version:
Keywords: Cc:

Description

The last few versions of josm complain on startup and request a bug report.
The program does continue and can be used for editing except that the measurement and
AgPifoj plugins do not work.


Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1998
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1998
Last Changed Date: 2009-08-27 14:24:03 +0200 (Thu, 27 Aug 2009)

Memory Usage: 17 MB / 63 MB (1 MB allocated, but free)
Java version: 1.6.0_14

Plugins: AgPifoJDirectUploadeditgpxmeasurementvalidator
Plugin AgPifoJ Version: 16941
Plugin DirectUpload Version: 16583
Plugin editgpx Version: 16793
Plugin measurement Version: 16801
Plugin validator Version: 17175

java.lang.NullPointerException

at org.openstreetmap.josm.gui.dialogs.ToggleDialog$3.actionPerformed(ToggleDialog.java:167)
at org.openstreetmap.josm.gui.dialogs.ToggleDialog$5.run(ToggleDialog.java:233)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by plaicy

Maybe this is a duplicate of #3315 (Stacktrace is the same). See also #3307. Try to remove all lines containing "docked" in your preference file. If JOSM works after this please close this ticket as duplicate and write "3315" in the text field.

comment:2 Changed 12 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [1999]) fixed #3349: Last 3 few versions of josm report error on start. Neither measurement nor AgPifoJ plugins then work

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.