Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2893 closed defect (fixed)

UtilsPlugin: Exception after simplifying a way

Reported by: grippon.sylvain@… Owned by: team
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: Cc: Gubaer

Description

Suite à simplification du chemin "Rue des Jasmins" à "La Remuée" Dalle 2052,1397

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1755
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1755
Last Changed Date: 2009-07-09 10:53:33 +0200 (Thu, 09 Jul 2009)

Memory Usage: 39 MB / 762 MB (7 MB allocated, but free)
Java version: 1.6.0_12

Plugins: cadastre-freditgpxutilspluginvalidatorwmsplugin
Plugin editgpx Version: 16294
Plugin utilsplugin Version: 16162
Plugin validator Version: 16409
Plugin wmsplugin Version: 16363
Plugin cadastre-fr Version: 16160

java.lang.NoSuchMethodError: org.openstreetmap.josm.Main.editLayer()Lorg/openstreetmap/josm/gui/layer/OsmDataLayer;

at UtilsPlugin.SimplifyWayAction.actionPerformed(SimplifyWayAction.java:42)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
at java.awt.Component.processMouseEvent(Component.java:6216)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
at java.awt.Component.processEvent(Component.java:5981)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4583)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (4)

comment:1 Changed 13 years ago by anonymous

Suite à simplification du chemin "Rue d'Alençon" à "La Remuée" Dalle 2052,1397 et non pas "Rue des Jasmins"

comment:2 Changed 13 years ago by Gubaer

Cc: Gubaer added
Component: CorePlugin
Resolution: fixed
Status: newclosed
Summary: Suite à Simplification d'un cheminUtilsPlugin: Exception after simplifying a way

Try the latest utilsplugin version built 16420. It should now be compatible with the latest core release r1758.

comment:3 Changed 13 years ago by grippon.sylvain@…

Yes OK it's good. Thanks.

comment:4 Changed 13 years ago by Gubaer

Ticket #2895 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.