Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2895 closed defect (duplicate)

Simplify way error with version 1758 (1755 too), ok with 1669

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: simplify way Cc: Gubaer

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1758
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1758
Last Changed Date: 2009-07-09 19:28:07 +0200 (Thu, 09 Jul 2009)

Memory Usage: 22 MB / 63 MB (4 MB allocated, but free)
Java version: 1.6.0_13

Plugins: DirectUpload
PicLayer
buildings_tools
dataimport
editgpx
openvisible
osmarender
tageditor
usertools
utilsplugin
validator
waydownloader
wmsplugin
Plugin DirectUpload Version: 15828
Plugin PicLayer Version: 16302
Plugin buildings_tools Version: 19
Plugin dataimport Version: 16382
Plugin editgpx Version: 16294
Plugin openvisible Version: 15707
Plugin osmarender Version: 16239
Plugin tageditor Version: 15707
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16162
Plugin validator Version: 16409
Plugin waydownloader Version: 16290
Plugin wmsplugin Version: 16363

java.lang.NoSuchMethodError: org.openstreetmap.josm.Main.editLayer()Lorg/openstreetmap/josm/gui/layer/OsmDataLayer;

at UtilsPlugin.SimplifyWayAction.actionPerformed(SimplifyWayAction.java:42)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 13 years ago by Gubaer

Cc: Gubaer added
Resolution: duplicate
Status: newclosed

comment:2 Changed 13 years ago by Gubaer

Closed as duplicate of #2893.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.