Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2821 closed defect (fixed)

Bilder sind nicht nachladbar für gpxtrack

Reported by: fahrradfahrer Owned by: team
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: AgPifo Cc:

Description

Beim zuordnen der Bilder unter AgPifo werden die Horizontalen und Vertikalen Werte vertauscht und werden somit an der falschen stelle angezeigt!!

Josm schreibt folgende Infos zur Fehlermeldung:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1732
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1732
Last Changed Date: 2009-07-04 22:32:30 +0200 (Sat, 04 Jul 2009)

Memory Usage: 403 MB / 444 MB (71 MB allocated, but free)
Java version: 1.6.0_13

Plugins: AgPifoJusertoolsvalidatorwmsplugin
Plugin AgPifoJ Version: 16294
Plugin usertools Version: 14125
Plugin validator Version: 16294
Plugin wmsplugin Version: 16308

java.lang.RuntimeException: java.lang.NullPointerException

at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:127)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Caused by: java.lang.NullPointerException

at org.openstreetmap.josm.gui.layer.GeoImageLayer.calculatePosition(GeoImageLayer.java:688)
at org.openstreetmap.josm.gui.layer.GeoImageLayer.access$300(GeoImageLayer.java:85)
at org.openstreetmap.josm.gui.layer.GeoImageLayer$Loader.realRun(GeoImageLayer.java:331)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:102)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by stoecker

Bitte etwas genauer beschreiben. Ich benutzt das Plugin nicht und muss trotzdem die Stelle im Quellcode finden. Ganz offentsichtlich ist der Fehler nicht, deswegen brauche ich einen bessere Beschreibung. Wo werden die Bilder angzeiget, was genau ist vertauscht (Bildschirmkoordinaten, ...)?

comment:2 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In r1733.

comment:3 Changed 10 years ago by stoecker

Nachtrag. Problem ist in Version r1733 von JOSM behoben. Der Fehler lag in JOSM, nicht im Plugin.

comment:4 Changed 10 years ago by stoecker

Ticket #2826 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by stoecker

Second Fix in r1737.

comment:6 Changed 10 years ago by stoecker

Ticket #2827 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.