Modify

Opened 15 years ago

Closed 15 years ago

#2820 closed defect (worksforme)

NoMethodError uploading a deleted former relation member

Reported by: anonymous Owned by: anonymous
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

How to reproduce:

  • Deleted a way which is a member of a relation
  • JOSM prompts with dialog "member of relation ###. Want to remove this way from the relation?"
  • Answered with "Yes, remove"
  • tried to upload changes. (I've attached an OSM-file containing one such deleted way which fails to upload

Result:

PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/1734245/upload... Internal Server Error
POST http://www.openstreetmap.org/api/0.6/changeset/1734245/upload... Internal Server Error
POST http://www.openstreetmap.org/api/0.6/changeset/1734245/upload... Internal Server Error
POST http://www.openstreetmap.org/api/0.6/changeset/1734245/upload... Internal Server Error
POST http://www.openstreetmap.org/api/0.6/changeset/1734245/upload... Internal Server Error
POST http://www.openstreetmap.org/api/0.6/changeset/1734245/upload... Internal Server Error
Error header: NoMethodError: undefined method `<' for nil:NilClass
PUT http://www.openstreetmap.org/api/0.6/changeset/1734245/close... OK
org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.io.OsmApiException: ResponseCode=500, Error Header=<NoMethodError: undefined method `<' for nil:NilClass>,Error Body=<NoMethodError: undefined method `<' for nil:NilClass

at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:333)
at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:105)
at org.openstreetmap.josm.actions.UploadAction$1UploadDiffTask.realRun(UploadAction.java:213)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:102)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:651)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:676)
at java.lang.Thread.run(Thread.java:613)

Caused by: org.openstreetmap.josm.io.OsmApiException: ResponseCode=500, Error Header=<NoMethodError: undefined method `<' for nil:NilClass>,Error Body=<NoMethodError: undefined method `<' for nil:NilClass

at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:445)
at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:330)

Attachments (1)

500error.osm (7.3 KB ) - added by Claudius 15 years ago.
deleted a way whuch is a relation member. upload failing

Download all attachments as: .zip

Change History (3)

by Claudius, 15 years ago

Attachment: 500error.osm added

deleted a way whuch is a relation member. upload failing

comment:1 by stoecker, 15 years ago

Owner: changed from team to anonymous
Status: newneedinfo

Which JOSM version?

comment:2 by Gubaer, 15 years ago

Resolution: worksforme
Status: needinfoclosed

This was most likely a temporary issue on the API server. The last URL you sent looks fine:

http://www.openstreetmap.org/api/0.6/changeset/1734245/close

Also, these InternalServerErrors are most likely due to a temporary server issue.

Let me know if you still have these kind of problems.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.