Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#2826 closed defect (duplicate)

Exception when trying to import image(s)

Reported by: jonass@… Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

I opened a gpx-track, downloaded the area from OSM and then tried to import photos.

This seems to happen when trying to import images withing the timespan of a gpx-track. Importing an image from outside the timespan works fine.

I am using JRE from Sun in Ubuntu 8.04.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1732
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1732
Last Changed Date: 2009-07-04 22:32:30 +0200 (Sat, 04 Jul 2009)

Memory Usage: 335 MB / 910 MB (140 MB allocated, but free)
Java version: 1.6.0_07

java.lang.RuntimeException: java.lang.NullPointerException

at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:127)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

Caused by: java.lang.NullPointerException

at org.openstreetmap.josm.gui.layer.GeoImageLayer.calculatePosition(GeoImageLayer.java:688)
at org.openstreetmap.josm.gui.layer.GeoImageLayer.access$300(GeoImageLayer.java:85)
at org.openstreetmap.josm.gui.layer.GeoImageLayer$Loader.realRun(GeoImageLayer.java:331)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:102)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)

Attachments (0)

Change History (2)

comment:1 by stoecker, 15 years ago

Resolution: duplicate
Status: newclosed

comment:2 by stoecker, 15 years ago

Closed as duplicate of #2821.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.