Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#2809 closed enhancement (fixed)

Change what "interesting direction hints" means

Reported by: augustus.kling@… Owned by: ulfl
Priority: minor Milestone:
Component: Internal mappaint style Version: latest
Keywords: oneway, direction hint Cc: nakor.wp@…

Description

The behavior of PreferencesDisplay SettingsOSM DataDraw Direction ArrowsOnly interesting direction hints is not optimal and sometimes confusing.

Arrows should not be shown for ways tagged as oneway=no as stated in #2387. Are the mentioned speed reasons longer valid for the current code base? If I understood the code correctly the checkDirectionTagged method of OsmPrimitive class is only called at changes of tags. Thus it should not matter a lot to also check a tag's value if the tag name was contained within directionKeys.

The direction hint arrows should also be displayed for waterways tagged as stream, river, canal and drain. This needs to be discussed here as the direction matters but does not automatically restrict the moving direction of boats (for example).

Additionally piste:type tags for the values downhill and sled as well as man_made=piste:halfpipe should receive direction hints.

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by jttt

I've tested using search pattern (as in Edit - Search action) instead of key list. The performance impact was negligible. I don't want to commit that now, because new JOSM tested is about to be released and I've also rewritten SearchAction a bit (so it's quite possible I broke something).

After new code is commited, it will be possible to use arbitrary condition when deciding whether arrows should be shown.

comment:2 Changed 10 years ago by Nakor

Cc: nakor.wp@… added

comment:3 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2883]) Fixed #2809 Change what "interesting direction hints" means

comment:4 Changed 10 years ago by bastiK

Ticket #3973 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by bastiK

Ticket #3273 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ulfl.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.