Modify

Opened 15 years ago

Closed 15 years ago

#2678 closed defect (fixed)

crash when moving cadastre layer

Reported by: renaud@… Owned by: pieren
Priority: major Milestone:
Component: Plugin cadastre-fr Version: latest
Keywords: cadastre-fr layer move Cc:

Description

Josm crashed when I tried to adjust the position of the layer provided by plugin Cadastre-fr, using the button on the right (the one with 4 direction arrows). I am using the latest versions of both prgm & plugin.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1629
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1629
Last Changed Date: 2009-05-30 17:24:29 +0200 (Sat, 30 May 2009)

Java version: 1.6.0_0
Plugins: cadastre-fr
Plugin cadastre-fr Version: 14121

java.lang.NullPointerException

at cadastre_fr.WMSLayer.displace(WMSLayer.java:461)
at cadastre_fr.WMSAdjustAction.displace(WMSAdjustAction.java:114)
at cadastre_fr.WMSAdjustAction.mouseDragged(WMSAdjustAction.java:99)
at java.awt.AWTEventMulticaster.mouseDragged(AWTEventMulticaster.java:320)
at java.awt.Component.processMouseMotionEvent(Component.java:6156)
at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3294)
at java.awt.Component.processEvent(Component.java:5877)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4469)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4142)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
at java.awt.Container.dispatchEventImpl(Container.java:2149)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (3)

comment:1 by anonymous, 15 years ago

Ticket #2681 has been marked as a duplicate of this ticket.

comment:2 by stoecker, 15 years ago

Component: PluginPlugin cadastre-fr
Owner: changed from team to pieren

comment:3 by pieren, 15 years ago

Resolution: fixed
Status: newclosed

Because you tried to displace a vectorized image which is not the aim of the function. It is originally implemented for raster images only because they are not georeferenced.

Fixed in cadastre-fr plugin file WMSAdjustAction.java, rev. 15841

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain pieren.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.