Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2677 closed defect (fixed)

Josm exception when trying to upload 2 new roads and 1 place

Reported by: PerroVerd Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by stoecker)

Last version with plugins just updated

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1629
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1629
Last Changed Date: 2009-05-30 17:24:29 +0200 (Sat, 30 May 2009)

Java version: 1.6.0_13
Plugins: lakewalkeropenstreetbugsusertoolsutilspluginvalidatorwmsplugin
Plugin lakewalker Version: 14015
Plugin openstreetbugs Version: 14826
Plugin usertools Version: 14125
Plugin utilsplugin Version: 15127
Plugin validator Version: 15127
Plugin wmsplugin Version: 15091

java.lang.NullPointerException

at java.util.LinkedList.addAll(LinkedList.java:269)
at java.util.LinkedList.addAll(LinkedList.java:247)
at java.util.LinkedList.<init>(LinkedList.java:98)
at org.openstreetmap.josm.actions.UploadAction$1.checkUpload(UploadAction.java:107)
at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:171)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
at java.awt.Component.processMouseEvent(Component.java:6216)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
at java.awt.Component.processEvent(Component.java:5981)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4583)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

I also have the osm file with the changes if needed

Attachments (1)

garde.osm.bz2 (29.0 KB) - added by PerroVerd 11 years ago.
Changes to reproduce the exception

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by PerroVerd

Attachment: garde.osm.bz2 added

Changes to reproduce the exception

comment:1 Changed 11 years ago by PerroVerd

More info, it works on version 1627 and 1629 in other machine. The only diference i see its the architecture x86 on the error machine and amd64 in the non error and also a small diference in java version 1.6.0_13 vs 1.6.0_0. Both machines running updated debian sid.

I've forget to mention that the error its produced after a warning about the road type on highways and before the screen with the listing of the changes and the option to introduce the comment.

Thanks in advance

comment:2 Changed 11 years ago by stoecker

Ticket #2679 has been marked as a duplicate of this ticket.

comment:3 Changed 11 years ago by stoecker

Description: modified (diff)
Resolution: fixed
Status: newclosed

Fixed in r1630.

comment:4 Changed 11 years ago by stoecker

Ticket #2680 has been marked as a duplicate of this ticket.

comment:5 Changed 11 years ago by anonymous

Ticket #2682 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.