Modify

Opened 19 months ago

Last modified 19 months ago

#22495 needinfo defect

Warning when using a relation restriction:bicycle=give_way

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Core validator Version: tested
Keywords: template_report restriction give_way Cc:

Description

What steps will reproduce the problem?

  1. Create a relation restriction:bicycle=give_way as an alternative to red_turn:right:bicycle=yes
  2. Click on Validate

What is the expected result? No warning

What happens instead? Warning "Error: Unknown turn restriction"

Please provide any additional information below. Attach a screenshot if possible.

https://media.joomeo.com/large/636e202c890ef.jpg

Revision:18583
Build-Date:2022-11-01 14:35:40

Identification: JOSM/1.5 (18583 fr) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19045)
Memory Usage: 720 MB / 1984 MB (314 MB allocated, but free)
Java version: 17.0.5+8-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1680×1050 (scaling 1.00×1.00)
Maximum Screen Size: 1680×1050
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: fr_FR
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-Djpackage.app-version=1.5.18583, --add-modules=java.scripting,java.sql,javafx.controls,javafx.media,javafx.swing,javafx.web, --add-exports=java.base/sun.security.action=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djpackage.app-path=%UserProfile%\AppData\Local\JOSM\JOSM.exe]
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (1537115529)
+ DirectDownload (36011)
+ PicLayer (1.0.2)
+ apache-commons (36003)
+ apache-http (35924)
+ buildings_tools (36011)
+ cadastre-fr (36021)
+ ejml (35924)
+ geotools (36028)
+ gridify (1606242219)
+ indoorhelper (1.2.2)
+ jackson (36006)
+ javafx (35807)
+ jaxb (35952)
+ jna (36005)
+ jogl (1.2.3)
+ jts (36004)
+ kendzi3d-resources (0.0.2)
+ log4j (36007)
+ measurement (35978)
+ photoadjust (36011)
+ pt_assistant (1ff2e15)
+ reverter (36011)
+ todo (30306)
+ tofix (490)
+ turnrestrictions (36011)
+ undelete (36011)
+ utilsplugin2 (36011)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/SidewalksAndFootways&zip=1
- <josm.pref>\plugins\indoorhelper\resources\sit.mapcss

Last errors/warnings:
- 00003.142 W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- 00009.216 E: java.security.KeyStoreException: Windows-ROOT not found. Cause : java.security.NoSuchAlgorithmException: Windows-ROOT KeyStore not available
- 00044.786 W: Not a single layer for the name 'Cadastre': []
- 00044.790 W: Not a single layer for the name 'Cadastre': []
- 00044.791 W: Not a single layer for the name 'Cadastre': []
- 00044.793 W: Not a single layer for the name 'Cadastre': []
- 00044.797 W: Not a single layer for the name 'Cadastre': []
- 00044.798 W: Not a single layer for the name 'Cadastre': []
- 00044.814 W: Not a single layer for the name 'Cadastre': []
- 00070.880 E: Impossible de trouver l'image "bus.png"

Attachments (0)

Change History (5)

comment:1 by skyper, 19 months ago

Keywords: restriction added
Resolution: duplicate
Status: newclosed
Version: tested

Closed as duplicate of #19722.

comment:2 by skyper, 19 months ago

Keywords: give_way added
Resolution: duplicate
Status: closedreopened

Oh, sorry, my bad.

I know highway=give_way but I do not find any documentation about restriction=give_way.

comment:3 by skyper, 19 months ago

Owner: changed from team to anonymous
Status: reopenedneedinfo

comment:5 by skyper, 19 months ago

Thanks.
Seems to be not well established,(yet). Please have a look at the discussion on the talk page.

  • Is a relation required or can this be tagged on the node of the highway=traffic_signals or highway=give_way?
    • Two different tagging system for the same feature might no be the best solution
  • restriction does not fit here as it is no restriction but rather the opposite.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as needinfo The owner will remain anonymous.
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from anonymous to the specified user. Next status will be 'new'.
as duplicate The resolution will be set to duplicate. Next status will be 'closed'. The specified ticket will be cross-referenced with this ticket.
The owner will remain anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.