Modify

Opened 3 years ago

Last modified 17 months ago

#21778 reopened defect

Validation error: oneway + oneway:conditional + bicycle:backwards:conditional

Reported by: Famlam Owned by: team
Priority: minor Milestone:
Component: Core validator Version:
Keywords: template_report dismount oneway conditional Cc:

Description (last modified by Famlam)

What steps will reproduce the problem?

  1. Validate way 110970935

What is the expected result?

No validation error

What happens instead?

Two validation errors

  1. dismount is not recognized as a valid access tag (I know this road, it literally says cyclists should dismount - in Dutch of course, when going downhill) by this test
  2. EDIT: Fixed by r18674 (was: It complains about bicycle:backward:conditional=dismount @ destination together with oneway=yes (from here) without taking into account oneway:conditional. )

Please provide any additional information below. Attach a screenshot if possible.

Suggested fixes:

  1. add dismount to this array: RESTRICTION_VALUES
  2. EDIT: Fixed by r18674 (was: add [!oneway:conditional] to https://josm.openstreetmap.de/browser/josm/trunk/resources/data/validator/combinations.mapcss lines 294-297 )
URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2022-01-02 21:24:43 +0100 (Sun, 02 Jan 2022)
Build-Date:2022-01-02 20:26:19
Revision:18360
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18360 nl) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19044)
Memory Usage: 568 MB / 1820 MB (160 MB allocated, but free)
Java version: 1.8.0_311-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: nl_NL
Numbers with default locale: 1234567890 -> 1234567890
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35893)
+ SimplifyArea (35893)
+ imagery_offset_db (35893)
+ pt_assistant (1ff2e15)
+ reverter (35893)
+ tageditor (35893)
+ turnlanes-tagging (v0.0.5)
+ undelete (35893)
+ utilsplugin2 (35893)

Tagging presets:
+ http://mijndev.openstreetmap.nl/~allroads/JOSM/Presets/NL-Fiets.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.mappaint.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1

Validator rules:
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.validator.mapcss

Last errors/warnings:
- 00008.302 E: Lokaliseren van afbeelding 'bus.png' mislukt
- 00053.304 E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=404
- 00053.323 E: Niet gevonden - <html>De OSM-server 'api.openstreetmap.org' kent geen object<br>dat u probeerde te lezen, bij te werken of te verwijderen. Ofwel bestaat het respectievelijke object<br>niet op de server of u gebruikt een ongeldige URL om er toegang<br>toe te krijgen. Controleer zorgvuldig het adres van de server 'api.openstreetmap.org' op typefouten.</html>
- 00055.151 E: java.lang.IllegalStateException: JOSM verwachtte een primitief [relatie 110970935] te vinden in de gegevensset, maar die is er niet. Rapporteer dit bij https://josm.openstreetmap.de. Dit is geen kritieke fout, u kunt veilig doorgaan met uw werk.

Attachments (0)

Change History (10)

comment:1 by skyper, 17 months ago

See also #18831, #21163 and #22714.

comment:2 by Famlam, 17 months ago

Made a PR to fix the non-Java part:
https://github.com/JOSM/josm/pull/112
(This PR thus only fixes half of the issue)

Last edited 17 months ago by Famlam (previous) (diff)

comment:3 by Famlam, 17 months ago

Summary: Validation error: oneway + oneway:conditional + bicycle:backwards:conditional[github patch] Validation error: oneway + oneway:conditional + bicycle:backwards:conditional

comment:4 by Famlam, 17 months ago

Summary: [github patch] Validation error: oneway + oneway:conditional + bicycle:backwards:conditional[patch][github patch] Validation error: oneway + oneway:conditional + bicycle:backwards:conditional

(It doesn't appear in the list of tickets with patches if I use [github patch])

comment:5 by taylor.smock, 17 months ago

Resolution: fixed
Status: newclosed

In 18674/josm:

Fix #21778: oneway + .*:(backward|forward):conditional should not have a warning (patch by Famlam)

comment:6 by taylor.smock, 17 months ago

Milestone: 23.02

comment:7 by Famlam, 17 months ago

Description: modified (diff)
Resolution: fixed
Status: closedreopened

Thank you taylor.smock!
Unfortunately my PR only fixed the second issue listed, not the first. The Java-test still needs to be updated to include dismount. Hence I re-opened this issue. (Not sure if I should remove the milestone as the other issues about the java test have no milestone)

comment:8 by Famlam, 17 months ago

Summary: [patch][github patch] Validation error: oneway + oneway:conditional + bicycle:backwards:conditionalValidation error: oneway + oneway:conditional + bicycle:backwards:conditional

comment:9 by taylor.smock, 17 months ago

Milestone: 23.02

We can move the milestone around. Technically, I could probably fix the java test right now, but I was hoping to do a release today. Which hasn't happened, since the CI system is blocked.

comment:10 by Famlam, 17 months ago

Thanks! Yes, the fix is very easy, but I was under the impression that the Java test would have to be rewritten given the number of errors (comment 1). Anyway, indeed, this fix is simple so it could be applied without waiting for a generic fix I guess.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from team to the specified user. Next status will be 'new'.
Next status will be 'needinfo'. The owner will be changed from team to Famlam.
as duplicate The resolution will be set to duplicate. Next status will be 'closed'. The specified ticket will be cross-referenced with this ticket.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.