Modify

Opened 14 months ago

Closed 14 months ago

Last modified 13 months ago

#21440 closed enhancement (duplicate)

Missing key barrier=height_restrictor

Reported by: Szem Owned by: team
Priority: normal Milestone:
Component: Internal preset Version:
Keywords: barrier height_restrictor Cc:

Description

I did not find the height_restrictor value among the barriers.

Attachments (11)

height_restrictor.svg (8.0 KB) - added by Szem 14 months ago.
height_restrictor-optimized.svg (671 bytes) - added by Szem 14 months ago.
height_restrictor_nosign-optimized.svg (589 bytes) - added by Szem 14 months ago.
Version without access road sign, I think it's worse than the original.
height_restrictor-v05-optimized.svg (818 bytes) - added by Szem 14 months ago.
I made two different variations. These look good on both dark and light backgrounds. Choose the one you like.
height_restrictor-v10-optimized.svg (975 bytes) - added by Szem 14 months ago.
height_restrictor-v05-optimized5.svg (1.9 KB) - added by skyper 14 months ago.
add more halo and gradient
height_restrictor-v05-optimized7.svg (1.5 KB) - added by skyper 14 months ago.
add multicolor gradient; fitting red boxes
log-v03-optimized.svg (3.1 KB) - added by Szem 13 months ago.
I've made a simple log. Is it OK?
log-v03.svg (9.8 KB) - added by Szem 13 months ago.
The original - not optimized - file.
crevasse-v02.svg (8.0 KB) - added by Szem 13 months ago.
I was done with the second one too. Although I don't know if you can recognize what it is (I don't think :)
logs.png (1.4 KB) - added by Szem 13 months ago.
I think there's a noticeable difference (16px), you can feel what it is with one and not with the other…

Download all attachments as: .zip

Change History (36)

comment:1 Changed 14 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19573.
See also #17750.
Most of the work is finding/creating a nice icon.

comment:2 Changed 14 months ago by Szem

How can I help with this? (format, size, etc.)

comment:3 Changed 14 months ago by skyper

Finding/Creating new icons is consuming 90% or more time creating new presets.

We need plain .svg icons without text elements, see DevelopersGuide/DefaultPresets.

Changed 14 months ago by Szem

Attachment: height_restrictor.svg added

comment:4 Changed 14 months ago by anonymous

I created the requested icon in 16px size and uploaded it as an attachment. Is this correct, or how / where can I upload it?

comment:5 Changed 14 months ago by skyper

Thanks, attaching the icon is perfect.

Some remarks about the icon:

  • we only need plain icons and not inkscape format which makes the file size smaller
  • Looking at the file in a text editor reveals some numbers like radius or stroke size which should be integer but are little off and rational numbers at the moment
  • the file contains quite a lot of unused gradients which is visible if you copy the elements to a new document and save it
  • what is the license of the file?
  • I think the access road sign on top is too much and might be misleading
  • I am not sure if the background is needed or if we can get enough contrast with only little halo

comment:6 Changed 14 months ago by Szem

First I found the inkscap as an svg editor. I had no intention of using a gradient, I don’t know how it got into it. Also for the sizes, I tried to give everything to an integer value of 16x16px. What program should I use? I'll edit with that.

comment:7 Changed 14 months ago by Szem

I found how to make an optimized svg, is it that right? The picture was taken by me for free of use.

Changed 14 months ago by Szem

comment:8 Changed 14 months ago by Szem

If there are other icons waiting to be created, where can I find a list of these?

Changed 14 months ago by Szem

Version without access road sign, I think it's worse than the original.

comment:9 Changed 14 months ago by skyper

Wow, this is really puristic. How did you optimize it?

I am by far an expert on images/icons and faced similar problems with inkscape regarding stroke width and radius. I now always take a look at the code with a text editor plus copy only the elements I need to a new document.
To be fair, a lot of icons in preset and style would profit from some polishing but that is quite some work. E.g. I have updated all power source icons while working on the power plant preset.

I like to have a similar look than other barriers like source:trunk/resources/images//presets/barrier/bollard.svg, source:trunk/resources/images//presets/barrier/lift_gate.svg, source:trunk/resources/images//presets/barrier/swing_gate.svg, source:trunk/resources/images//presets/barrier/kissing_gate.svg but I have to admit that I did not take a look at the source code of the icons and the lifting and swinging gate could be a bit thicker. I do not know why gate source:trunk/resources/images//presets/barrier/gate.svg has a blue background.

No, there is no list of missing/needed icons. #21396 is one ticket but you might find some more taking a look at the ticket about presets and styles

comment:10 Changed 14 months ago by Szem

First question: is this the best way to discuss, or is there another simpler alternative?
Create a minimized icon: inkscape / Save as a copy / Optimized SVG format + manual edit if needed.
I’m happy to help tidy up the icons because I don’t like the fact that each one looks completely different.
I only drew a background because I read that there is no black or white color in it without an extra outline, or is that not true?
What should be the solution? Is there a forum where you need to discuss what the standard look should be? Or which one don't like we redraw?

comment:11 Changed 14 months ago by skyper

Perfect, we definitely need help with icons.

Ok, we have several communication channels but the ticket system is the main part. Discussing in a ticket which is closed and which is only about height_restrictor might be wrong but the channel is correct. How about a new ticket for preset and style icons in general.

Regarding the background: Yes it is true that the icon needs enough contrast or casing and colorful icons are preferred. It should also be visible on different backgrounds like black and white because there might be no imagery (black) or a light or even white one. Additionally, in presets and other GUI parts the background color of the LaFs can cover the full spectrum.
See my comment and following on #20530, for example.

How about using a dark gray with little white casing for the vertical parts and a black casing for the horizontal white and red bar? I'd either convert the strokes in paths to use different fill and stoke colors or add a new element below with little bigger dimension.

comment:12 Changed 14 months ago by anonymous

The new ticket is ok, although for me all of them are just as cumbersome (I don't see, for example, when a response arrives).
At home I will see what it will be like with a 1px gray / white outline and upload it.
Regarding the new icons: I’ll look at the “gate” first to see what I can get out of it.

comment:13 Changed 14 months ago by skyper

Mmh, you should get an email about comments and changes of a ticket if

  • you are the reporter of the ticket
  • you have commented on the ticket
  • your nickname/email is added to cc

Obviously, the first two option only work if you are logged in or supply an email address. In trac's user preferences there is an option to disable email notification but default is to send emails.

1px for outline might be too much. I thought about 0.2 but it is always useful to check with the Styles/IconTester.

Last edited 14 months ago by skyper (previous) (diff)

comment:14 Changed 14 months ago by Szem

Now that I have registered I may be receiving an email :)

Changed 14 months ago by Szem

I made two different variations. These look good on both dark and light backgrounds. Choose the one you like.

Changed 14 months ago by Szem

Changed 14 months ago by skyper

add more halo and gradient

comment:15 Changed 14 months ago by skyper

I have upgraded the icon what do you think: add more halo and gradient add more halo and gradient

comment:16 Changed 14 months ago by skyper

Tidying the source code after changes in inkscape is no fun an error prone. I wish we'd have/find a script for it.

comment:17 in reply to:  12 Changed 14 months ago by skyper

Replying to anonymous:

The new ticket is ok, although for me all of them are just as cumbersome (I don't see, for example, when a response arrives).

I have created #21482 and hope you already received an email.

Regarding the icons, I think I have to learn how to create gradients between different colors and not just using opacity.

comment:18 in reply to:  15 Changed 14 months ago by Szem

Replying to skyper:

I have upgraded the icon what do you think: add more halo and gradient add more halo and gradient

It's ok for me

Changed 14 months ago by skyper

add multicolor gradient; fitting red boxes

comment:19 Changed 14 months ago by skyper

Little more enhanced, my final version: add multicolor gradient; fitting red boxes add multicolor gradient; fitting red boxes

@Szem:
Are you ok with GPL3 as license or do you prefer PD or CC0?

comment:20 Changed 14 months ago by skyper

Oh, I tried using patterns but JOSM or svg-salamander does not like it.

comment:21 in reply to:  16 Changed 14 months ago by skyper

Replying to anonymous:

Regarding the new icons: I’ll look at the “gate” first to see what I can get out of it.

Ok, but actually we need an icon for barrier=log (#19573) and natural=crevasse + man_made=courtyard (#21396). So if you find one or you have an idea, I am happy.

Replying to skyper:

Tidying the source code after changes in inkscape is no fun an error prone. I wish we'd have/find a script for it.

I found that inkscape offers to save as "optimized" svg which is what we need.

Last edited 14 months ago by skyper (previous) (diff)

comment:22 in reply to:  19 ; Changed 13 months ago by anonymous

Replying to skyper:

Little more enhanced, my final version: add multicolor gradient; fitting red boxes add multicolor gradient; fitting red boxes

@Szem:
Are you ok with GPL3 as license or do you prefer PD or CC0?

I think the GPL3 is ok for me.

comment:23 in reply to:  22 Changed 13 months ago by Szem

Replying to névtelen:

Replying to skyper:

Little more enhanced, my final version: add multicolor gradient; fitting red boxes add multicolor gradient; fitting red boxes

@Szem:
Are you ok with GPL3 as license or do you prefer PD or CC0?

I think the GPL3 is ok for me.

Sorry, I didn't notice I logged out :)

comment:24 Changed 13 months ago by Klumbumbus

In 18296/josm:

fix #19573, see #21440 - Add some more barrier values (patch by skyper):

  • barrier=log (icon derived from https://openclipart.org/detail/252925/log, PD and CC0 licensed)
  • barrier=full-height_turnstile (icon created by skyper, GPL3 licensed)
  • barrier=height_restrictor (icon created by Szem and skyper, GPL3 licensed)

Changed 13 months ago by Szem

Attachment: log-v03-optimized.svg added

I've made a simple log. Is it OK?

Changed 13 months ago by Szem

Attachment: log-v03.svg added

The original - not optimized - file.

Changed 13 months ago by Szem

Attachment: crevasse-v02.svg added

I was done with the second one too. Although I don't know if you can recognize what it is (I don't think :)

comment:25 Changed 13 months ago by Klumbumbus

  • crevasse can be discussed further here: ticket:21396#comment:11
  • I think the current log icon is better, especially at larger sizes. At 16px there is no big difference between the two.

Changed 13 months ago by Szem

Attachment: logs.png added

I think there's a noticeable difference (16px), you can feel what it is with one and not with the other...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.