Modify

Opened 8 months ago

Last modified 7 months ago

#21364 reopened defect

GPX export of image new position use old coordinates

Reported by: StephaneP Owned by: StephaneP
Priority: normal Milestone: 21.10
Component: Core image mapping Version:
Keywords: template_report support-layer gpx Cc: Don-vip

Description (last modified by StephaneP)

What steps will reproduce the problem?

  1. Load some images (https://josm.openstreetmap.de/attachment/ticket/21330/bug_support_layer_A.zip)
  2. Export a gpx from these images, and load it in Josm
  3. Open the Correlate image with gpx window, and create a support layer from the previous exported Gpx
  4. Enable "override position", move some images, and validate the correlation.
  5. Export a gpx from the image positions then load it in Josm

What is the expected result?

The new exported Gpx point should be the same as the images.

What happens instead?

The exported Gpx file use the old images coordinates.

Please provide any additional information below. Attach a screenshot if possible.

On this screenshot, image with new coordinates, and the exported gpx.


The same process without the support layer, but with manual image (photo adjust plugin) position modification is working correctly.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-09-15 00:16:42 +0200 (Wed, 15 Sep 2021)
Build-Date:2021-09-15 01:31:02
Revision:18225
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18225 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19043)
Memory Usage: 2674 MB / 7218 MB (517 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: en_FR
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ DxfImport (1014)
+ Mapillary (2.0.0-alpha.36-dirty)
+ OpeningHoursEditor (35640)
+ PicLayer (1.0.1)
+ apache-commons (35524)
+ apache-http (35589)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ cadastre-fr (35797)
+ continuosDownload (99)
+ contourmerge (v0.1.8)
+ ejml (35458)
+ geotools (35458)
+ jaxb (35543)
+ jna (35662)
+ jts (35458)
+ log4j (35458)
+ measurement (35640)
+ opendata (35803)
+ photo_geotagging (35783)
+ photoadjust (35770)
+ reverter (35732)
+ shrinkwrap (v1.0.4)
+ tageditor (35640)
+ todo (30306)
+ turnlanes-tagging (288)
+ turnrestrictions (35640)
+ undelete (35640)
+ utilsplugin2 (35792)

Tagging presets:
+ %UserProfile%\Documents\Gitlab\preset-josm-collectivites\Presets-collectivités.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ %UserProfile%\Documents\GitHub\MapCSS-JOSM-Bicycle\cycleway.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1

Last errors/warnings:
- 81699.827 W: java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.827 W: Already here java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.828 W: Already here java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.828 W: java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.829 W: Already here java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.830 W: java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.831 W: java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.831 W: Already here java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.832 W: Already here java.net.UnknownHostException: wms.openstreetmap.fr
- 81699.833 W: Already here java.net.UnknownHostException: wms.openstreetmap.fr

Attachments (1)

old_position.jpg (53.5 KB) - added by StephaneP 8 months ago.

Download all attachments as: .zip

Change History (9)

Changed 8 months ago by StephaneP

Attachment: old_position.jpg added

comment:1 Changed 8 months ago by StephaneP

Description: modified (diff)

comment:2 Changed 8 months ago by Don-vip

Milestone: 21.09

comment:3 Changed 8 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:4 Changed 8 months ago by Don-vip

Owner: changed from Don-vip to StephaneP
Status: assignedneedinfo

Can't reproduce with JOSM 18240 it may have been fixed in r18233. Can you please check?

comment:5 Changed 8 months ago by StephaneP

Yes, it is fixed. Thanks!

comment:6 Changed 8 months ago by StephaneP

Resolution: fixed
Status: needinfoclosed

comment:7 Changed 8 months ago by Don-vip

Milestone: 21.0921.10

Milestone renamed

comment:8 Changed 7 months ago by StephaneP

Resolution: fixed
Status: closedreopened

Since some releases, I noticed this bug is back. (tested with r18321)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain StephaneP.
as The resolution will be set.
to The owner will be changed from StephaneP to the specified user.
The owner will change to StephaneP
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.