Modify

Opened 4 months ago

Closed 4 months ago

#21363 closed defect (duplicate)

Unknown conditional restriction

Reported by: fidelis.assis@… Owned by: team
Priority: normal Milestone:
Component: Core validator Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. create a turn restriction:
  2. type = restriction
  3. restriction:hgv:conditional = no_left_turn @ (Mo-Fr 06:00-20:00; Sa 06:00-13:00)

What is the expected result?

I suppose it should be accepted by JOSM

What happens instead?

JOSM complains: Unknown restriction

Please provide any additional information below. Attach a screenshot if possible.

That specific restrition can be seen at
https://www.openstreetmap.org/edit?relation=13131420#map=18/-3.73652/-38.49077

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-09-03 03:12:33 +0200 (Fri, 03 Sep 2021)
Revision:18193
Build-Date:2021-09-03 01:31:19
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (18193 pt_BR) Linux Ubuntu 18.04.6 LTS
Memory Usage: 356 MB / 3936 MB (199 MB allocated, but free)
Java version: 11.0.2+9-LTS, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: pt_BR.UTF-8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: pt_BR
Numbers with default locale: 1234567890 -> 1234567890
Desktop environment: ubuntu:GNOME
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20171026-2
Dataset consistency test: No problems found

Plugins:
+ Mapillary (2.0.0-alpha.35-dirty)
+ apache-commons (35524)
+ apache-http (35589)
+ ejml (35458)
+ geotools (35458)
+ jaxb (35543)
+ jna (35662)
+ jts (35458)
+ opendata (35803)
+ poly (35640)
+ reverter (35732)
+ utilsplugin2 (35792)

Last errors/warnings:
- 00022.408 E: Falha ao localizar imagem 'object-sign-other'
- 00022.417 E: Falha ao localizar imagem 'construction--barrier--concrete-block'
- 00022.417 E: Falha ao localizar imagem 'construction--barrier--concrete-block'
- 00022.431 E: Falha ao localizar imagem 'construction--barrier--concrete-block'
- 00022.432 E: Falha ao localizar imagem 'construction--barrier--concrete-block'
- 00022.433 E: Falha ao localizar imagem 'object-sign-other'

Attachments (0)

Change History (2)

comment:1 Changed 4 months ago by taylor.smock

Component: CoreCore validator

From https://wiki.openstreetmap.org/wiki/Relation:restriction#Tags, it looks like that is valid tagging.

comment:2 Changed 4 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20832.
See also #19722

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.