Modify

Opened 8 months ago

Closed 8 months ago

#20897 closed defect (duplicate)

IAE at org.openstreetmap.josm.plugins.mapillary.data.image.MapillarySequence.previous

Reported by: jorge.aguirre@… Owned by: taylor.smock
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

I was scrolling the Mapillary imagery while following a route, when there appeared a notice that read:

"Update plugins
An unexpected exception occurred that may have come from the 'Mapillary' plugin. According to the information within the plugin, the author is nokutu, floscher <incoming+josm-plugin-mapillary-8564565-issue-@…>. Try updating to the newest version of this plugin before reporting a bug."

I did as suggested without any results.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-04-27 20:35:33 +0200 (Tue, 27 Apr 2021)
Build-Date:2021-04-27 21:58:39
Revision:17833
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17833 en) Mac OS X 10.16
OS Build number: macOS 11.3.1 (20E241)
Memory Usage: 1706 MB / 1820 MB (129 MB allocated, but free)
Java version: 1.8.0_291-b10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69732992 1440×900 (scaling 1.00×1.00) Display 188956746 3840×2160 (scaling 1.00×1.00) Display 188956681 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 3840×2160
Best cursor sizes: 16×16→16×16, 32×32→32×32
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-Djava.security.policy=file:<java.home>/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/56/1ee8cfb8-59c767b8, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Dmacosx.jnlpx.dock.name=JOSM, -Dmacosx.jnlpx.dock.icon=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/25/4c122699-42421e5d.icns, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp , -Djnlpx.jvm="<java.home>/bin/java"]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.37.6)
+ apache-commons (35524)
+ apache-http (35589)
+ auto_tools (73)
+ buildings_tools (35740)
+ changeset-viewer (25)
+ easypresets (1616854084)
+ graphview (35640)
+ intersection (0.0.7)
+ jna (35662)
+ markseen (14)
+ openqa (0.2.1)
+ osm-obj-info (56)
+ rex (53)
+ tageditor (35640)
+ turnlanes (35640)
+ turnrestrictions (35640)
+ utilsplugin2 (35691)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Overlapping%20Ways.mapcss 
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart-Styles.mapcss 

Validator rules:
+  https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.clingstone.validator.mapcss
+ https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.clingstone.validator.mapcss 

Last errors/warnings:
- 14209.197 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.546 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.554 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.559 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.565 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.570 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.576 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.581 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.586 E: Handled by bug report queue: java.lang.IllegalArgumentException
- 14209.590 E: Handled by bug report queue: java.lang.IllegalArgumentException



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-2 (52) of javawsApplicationThreadGroup
java.lang.IllegalArgumentException
	at org.openstreetmap.josm.plugins.mapillary.data.image.MapillarySequence.previous(MapillarySequence.java:176)
	at org.openstreetmap.josm.plugins.mapillary.data.image.MapillaryAbstractImage.previous(MapillaryAbstractImage.java:282)
	at org.openstreetmap.josm.plugins.mapillary.actions.SelectNextImageAction.lambda$static$398c2a22$1(SelectNextImageAction.java:41)
	at org.openstreetmap.josm.plugins.mapillary.actions.SelectNextImageAction.actionPerformed(SelectNextImageAction.java:70)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1668)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2882)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2974)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2966)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2845)
	at java.awt.Component.processEvent(Component.java:6316)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:835)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1103)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:974)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:800)
	at java.awt.Component.dispatchEventImpl(Component.java:4760)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 8 months ago by skyper

Component: CorePlugin mapillary
Description: modified (diff)
Owner: changed from team to taylor.smock
Summary: I was scrolling the Mapillary imagery while following a route, when there appeared a notice that read "Update plugins / An unexpected exception occurred that may have come from the 'Mapillary' plugin. According to the information within the plugin, the author is nokutu, floscher <incoming+josm-plugin-mapillary-8564565-issue-@incoming.gitlab.com>. Try updating to the newest version of this plugin before reporting a bug." I did as suggested without any results.IAE at org.openstreetmap.josm.plugins.mapillary.data.image.MapillarySequence.previous

Probably, just a variant of #20586.

comment:2 Changed 8 months ago by taylor.smock

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20586.
@jorge.aguirre: If you are using josm-latest, you shouldn't run into this again. (The mapillary plugin is currently running an alpha version for the Mapillary v4 API, and this code was entirely rewritten for that).

@skyper: I agree with that assessment.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain taylor.smock.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.