Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 weeks ago

#20885 closed defect (fixed)

NoSuchFieldError using BuildingTools Plugin

Reported by: mdk Owned by: Upliner
Priority: normal Milestone:
Component: Plugin buildings_tools Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Draw a Building using BuildigTools

What is the expected result?

No Exception

What happens instead?

Some times I get java.lang.NoSuchFieldError: way
and I must uninstall the plugin.

Please provide any additional information below. Attach a screenshot if possible.

It looks like tis is not a problem with the plugin, but with the core. I got similar Problems with the ConturMerge Plugin (see #20882) and other user witb #20876.

For mee this a total blocker using the latest version!

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-05-13 19:28:55 +0200 (Thu, 13 May 2021)
Revision:17892
Build-Date:2021-05-14 01:31:02
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17892 en) Linux Ubuntu 20.10
Memory Usage: 1157 MB / 1980 MB (266 MB allocated, but free)
Java version: 15.0.3+3-Ubuntu-120.10, Private Build, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 3840×2160 (scaling 2.00×2.00)
Maximum Screen Size: 3840×2160
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: de_CH.UTF-8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_CH
Numbers with default locale: 1234567890 -> 1234567890
Desktop environment: ubuntu:GNOME
Java ATK Wrapper package: libatk-wrapper-java:all-0.38.0-1
libcommons-compress-java: libcommons-compress-java:all-1.20-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20200323-1build1
VM arguments: [--add-modules=java.scripting,java.sql, -Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35640)
+ HouseNumberTaggingTool (35640)
+ OpeningHoursEditor (35640)
+ RoadSigns (35640)
+ SimplifyArea (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ buildings_tools (35740)
+ imagery-xml-bounds (35723)
+ imagery_offset_db (35640)
+ jna (35662)
+ pbf (35720)
+ poly (35640)
+ public_transport (35640)
+ reltoolbox (35640)
+ reverter (35732)
+ terracer (35640)
+ turnrestrictions (35640)
+ utilsplugin2 (35691)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1

Last errors/warnings:
- 00571.121 E: Handled by bug report queue: java.lang.NoSuchFieldError: way



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.NoSuchFieldError: way
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.getEastNorth(DrawBuildingAction.java:224)
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.modeDrawingWidth(DrawBuildingAction.java:265)
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.processMouseEvent(DrawBuildingAction.java:288)
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.mouseMoved(DrawBuildingAction.java:426)
	at java.desktop/java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:338)
	at java.desktop/java.awt.Component.processMouseMotionEvent(Component.java:6659)
	at java.desktop/javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3360)
	at java.desktop/java.awt.Component.processEvent(Component.java:6383)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:4990)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4822)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4919)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4561)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4489)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2769)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4822)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (1)

20885.patch (1.2 KB) - added by taylor.smock 5 months ago.
Bump version number

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 months ago by gaben

Ticket #20886 has been marked as a duplicate of this ticket.

Changed 5 months ago by taylor.smock

Attachment: 20885.patch added

Bump version number

comment:3 Changed 5 months ago by taylor.smock

Resolution: fixed
Status: newclosed

In 35744/osm:

buildings_tools: recompile for compatibility with JOSM r17867, fixes #20885

comment:4 Changed 5 months ago by skyper

Ticket #20972 has been marked as a duplicate of this ticket.

comment:5 Changed 8 weeks ago by skyper

Ticket #21267 has been marked as a duplicate of this ticket.

comment:6 Changed 5 weeks ago by taylor.smock

Ticket #21361 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.