Modify

Opened 4 months ago

Closed 4 months ago

#21361 closed defect (duplicate)

building_tools: NoSuchFieldError: way

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin buildings_tools Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-09-03 03:12:33 +0200 (Fri, 03 Sep 2021)
Build-Date:2021-09-03 01:31:19
Revision:18193
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18193 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19042)
Memory Usage: 527 MB / 1742 MB (60 MB allocated, but free)
Java version: 1.8.0_301-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35640)
+ PolygonCutOut (v0.7)
+ apache-commons (35524)
+ buildings_tools (35740)
+ contourmerge (v0.1.4)
+ ejml (35458)
+ geotools (35458)
+ imagery_offset_db (35640)
+ jaxb (35543)
+ jts (35458)
+ mapathoner (1.1.10)
+ opendata (35803)
+ pdfimport (35640)
+ reverter (35732)
+ utilsplugin2 (35792)

Map paint styles:
+ https://github.com/osmlab/appledata/archive/josm_paint_inline_validation.zip
+ https://github.com/MissingMaps/josm_styles/archive/master.zip

Last errors/warnings:
- 11836.137 W: JCS - Silent failure during download: https://tile.openstreetmap.org/16/33556/25604.png
- 11836.442 W: JCS - Silent failure during download: https://tile.openstreetmap.org/17/67111/51204.png
- 14667.757 E: Handled by bug report queue: java.lang.NoSuchFieldError: way
- 14669.050 E: Handled by bug report queue: java.lang.NoSuchFieldError: way
- 14670.347 W: Unable to detect current tested version of JOSM:: java.nio.file.FileAlreadyExistsException: <josm.cache>\mirror_https___josm.openstreetmap.de_tested.tmp
- 14792.803 E: Handled by bug report queue: java.lang.NoSuchFieldError: way
- 14867.843 E: Handled by bug report queue: java.lang.NoSuchFieldError: way
- 14961.475 E: Handled by bug report queue: java.lang.NoSuchFieldError: way
- 26613.187 E: Handled by bug report queue: java.lang.NoSuchFieldError: way
- 30188.331 E: Handled by bug report queue: java.lang.NoSuchFieldError: way



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NoSuchFieldError: way
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.getEastNorth(DrawBuildingAction.java:224)
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.drawingStart(DrawBuildingAction.java:314)
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.mousePressed(DrawBuildingAction.java:364)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 4 months ago by taylor.smock

Resolution: invalid
Status: newclosed

The current version of building_tools should be 35756. You are currently running 35740. Please update your plugins.

comment:2 Changed 4 months ago by taylor.smock

Component: CorePlugin buildings_tools
Summary: Whenever click ,I get stuck and this widow opensbuilding_tools: NoSuchFieldError: way

comment:3 Changed 4 months ago by taylor.smock

Resolution: invalid
Status: closedreopened

comment:4 Changed 4 months ago by taylor.smock

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #20885.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.