Modify

Opened 3 months ago

Closed 3 months ago

#20320 closed defect (worksforme)

Icons are way too small on big screens

Reported by: tykayn Owned by: tykayn
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. open JOSM on a big screen, like 4K
  2. try to see icons
  3. they are not distinguible, here is a screenshot

What is the expected result?

i expect to see nice pictos, scaled relatively to screen size

What happens instead?

icons are not visible

Please provide any additional information below. Attach a screenshot if possible.

https://www.cipherbliss.com/wp-content/uploads/2020/12/josm_Capture-decran-de-2020-12-29-11-03-32.png
here is an example of a bench icon, under the cursor.
with imagery it is very hard to see until i pass the cursor on it. icons should be scaled and vectorial.
also tried enabling assistive technology and big texts, it does not apply to icons or texts of JOSM.

Attachments (1)

josm_Capture d’écran de 2020-12-29 11-03-32.png (1.3 MB) - added by tykayn 3 months ago.
example of small icons

Download all attachments as: .zip

Change History (7)

Changed 3 months ago by tykayn

example of small icons

comment:1 Changed 3 months ago by skyper

Description: modified (diff)
Owner: changed from team to tykayn
Status: newneedinfo

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.



You need to enable HiDPI support.

comment:2 Changed 3 months ago by tykayn

i followed instructions for hidpi support and the editor still has some issues,
font size are scaled up, but not the containers of all fonts, hence lot of things are still not readable and overflowing containers.

screenshots here
https://mastodon.cipherbliss.com/@tykayn/105485639139154404

comment:3 in reply to:  1 Changed 3 months ago by skyper

@tykayn:
In order to give you proper advises instead of guessing, we need more information about your system and your configurations. Would you, please, add your status report, thanks.

Replying to skyper:

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
    • Please, use source:trunk/resources/images/bug.svg Report Bug from Help menu and copy & paste.

comment:4 Changed 3 months ago by tykayn

sorry i missed that report part, here it is

ok so the akismet antipam doesnt like my paste, so here is a pastbin report.
https://pastebin.com/QbL6nvC7

comment:5 Changed 3 months ago by skyper

Ok, on Linux you need to use java 9 or later, e.g. openjdk-11-jre, for proper support of HiDPI. See Help/HiDPISupport.

comment:6 Changed 3 months ago by Klumbumbus

Resolution: worksforme
Status: needinfoclosed

Yes, with Java 8 it won't work on hidpi screens (for all operating systems, not only linux). Try out the latest java version. It should be 14 or 15 atm.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain tykayn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.