Modify

Opened 18 months ago

Closed 18 months ago

Last modified 10 months ago

#20318 closed defect (fixed)

Asking to tag segregated=no on highway=footway bicycle=yes is pointless

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 21.02
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. Create way with highway=footway bicycle=yes
  2. Run validator

What is the expected result?

Nothing, as in this case segregated=no is obvious (and that is why for example StreetComplete is not asking people to tag segregated)

After all, if bicycles would have its own designated space, then it would be bicycle=designated, right?

What happens instead?

JOSM spams "missing tag - Combined foot- and cycleway without segregated. (18)"

Please provide any additional information below. Attach a screenshot if possible.

See #17973

See https://www.openstreetmap.org/way/25463963

See also https://wiki.openstreetmap.org/wiki/Talk:Key:segregated#What_about_highway.3Dfootway_bicycle.3Dyes

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-27 20:15:27 +0100 (Sun, 27 Dec 2020)
Revision:17426
Build-Date:2020-12-28 02:30:52
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17426 en_GB) Linux Ubuntu 20.04.1 LTS
Memory Usage: 494 MB / 3974 MB (249 MB allocated, but free)
Java version: 11.0.9.1+1-Ubuntu-0ubuntu1.20.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Desktop environment: LXQt
Java package: openjdk-11-jre:amd64-11.0.9.1+1-0ubuntu1~20.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
Environment variable LANG: en_GB.UTF-8
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
Dataset consistency test: No problems found

Attachments (0)

Change History (17)

comment:1 Changed 18 months ago by mkoniecz

Description: modified (diff)

comment:2 Changed 18 months ago by mkoniecz

Description: modified (diff)

comment:3 Changed 18 months ago by gaben

Why is it obvious?

comment:4 Changed 18 months ago by mkoniecz

In case of bicycles have its own separate, designated space, then correct access would be bicycle=designated, right?

I am not 100% sure, access tagging is complex so maybe asking on tagging mailing list would be a good idea.

comment:5 Changed 18 months ago by GerdP

I also think that a way with tags

bicycle=yes
foot=yes
highway=path

is not meant by the wiki about segregated. The wiki says "This key is used for designated combined cycle- and footways"
and I understand this as both foot and bicycle are designated, not just allowed.

comment:6 in reply to:  5 ; Changed 18 months ago by Klumbumbus

Replying to GerdP:

and I understand this as both foot and bicycle are designated, not just allowed.

The questioned rule of this ticket comes from #17973 when the wiki said "This key has no default value and should be tagged on all shared ways!". At this time I understood "all shared ways" as all combinations of bicycle=* with foot=*. Limiting it to designated values only probably makes more sense, as you say.

comment:7 Changed 18 months ago by Klumbumbus

Milestone: 21.01

comment:8 in reply to:  6 Changed 18 months ago by gaben

Replying to Klumbumbus:

At this time I understood "all shared ways" as all combinations of bicycle=* with foot=*.

You understood back then correctly the wiki has been edited since then :) I'm saying the same, it makes more sense this way.

Otherwise, I agree with @GerdP. The ticket's original example is problematic, because "segregated=no is obvious" is an error. Segregated should be null here if I can say that.

comment:9 Changed 18 months ago by Klumbumbus

I saw that the wiki was changed. But I think even back then with the old text it was already meant for ways with two designated values only.

comment:10 Changed 18 months ago by GerdP

Resolution: fixed
Status: newclosed

In 17457/josm:

fix #20318: Asking to tag segregated=no on highway=footway bicycle=yes is pointless

  • only complain about missing segregated tag if way is designated for bicycle AND foot

comment:11 Changed 17 months ago by stoecker

Milestone: 21.0121.02

Milestone renamed

comment:12 Changed 15 months ago by goodidea

Hello!

I just read that with interest ... is it really so easy that segregated is meant only for ways with two designated values for foot + bicycle?

The logic that the wiki only mentions and shows such examples doesn't mean that footways with foot=designated and bicycle=yes (NOT designated) DO NOT exist with segregated ways. Or is meant in this way, that the segregated tag should not be used or only be optional in such cases (and so it's not a case for a validation warning)?

So, I would clearly contradict to the sentence: "if bicycles would have its own designated space, then it would be bicycle=designated, right?" => NO, it's a wrong conclusion. It also can be bicycle=yes.

The space for the bicycle may be separated or segregated on footways with bicycle=yes, but it must NOT be a way with "bicycle=designated". Because this has another meaning (under the current agreements and documentation in the wiki as far as I know) – it means, that you HAVE to use this way, and may not use a parallel street for example. That's also the difference of signs with bicycle="yes" vs. bicycle="designated".

I know some examples in my city of such ways with foot=designated, bicycle=yes and segregated=yes. And following the logic above, wouldn't ONE counter example be enough to falsify this "rule"? Here is one:

  • And the following pedestrian/bicycle crossing also has segregated ways: https://www.openstreetmap.org/way/833631510 and it is correctly tagged with "bicycle=yes" like the way before and not "bicycle=designated" – you can also use the street by bicycle if you want, so it is NOT designated for bicycles, even if it is a segregated foot/bicycle way. The sign is also very clear about that.

I only want to say and show, that it can be quite a litte mess with such ways in reality ... and that is not a very rare case.

So is segregated (and its check) not also "valid" and reasonable for designated footways with bicycle=yes, and perhaps only quite unnecessary with highway=path or highway=track (and foot=null or yes and bicycle=null or yes)?

comment:13 Changed 15 months ago by skyper

Yes, at least in Germany, I find highway=path, foot=designated, bicycle=yes and segregated=yes. As footway and cycleway with foot=[yes|designated] and bicycle=[yes|designated] are invalid in Germany, anyway, this rule might fit in the Rules/GermanySpecific.

comment:14 Changed 15 months ago by GerdP

How do you detect that the way is segregated when there is no corresponding sign?

comment:15 Changed 15 months ago by skyper

It is the lane_marking and the symbols on the ground. The usual case are former combined + segregated ways where the "blue sign" was changed but the lane markings and symbols still exist. As a cyclist you are only allowed to use the former designated part but pedestrian are allowed on "both sides" and for sure cyclist have to respect that these ways are designated for "foot", now, and "bicycle" is only allowed.

Last edited 15 months ago by skyper (previous) (diff)

comment:16 Changed 15 months ago by GerdP

As a cyclist you are only allowed to use the former designated part

That's new to me. Doesn't the sign (DE:239,1022-10) say that a cyclist can chose freely?

comment:17 in reply to:  14 Changed 10 months ago by goodidea

Replying to GerdP:

How do you detect that the way is segregated when there is no corresponding sign?

In my case (see comment 12) there are no old markings (symbols) on the way, but there are 2 different surfaces – at least on some parts of the way (asphalt left and paving stones right). And there are street crossings on the way where the side for bicycles has the typical red colour – and this part continues after the crossing with the asphalt surface ...

I made some photos in April and put it in Mapillary. You can see it quite good here:

https://www.mapillary.com/app/?pKey=1487129391650794

What you see in Mapillary is this part of the way (plus the crossings):

It's clear that the sign says that pedestrians may walk everywhere and cyclists, too - with due respect to the pedestrians. Officially/legally there is no segregation. But in reality, the cyclists are ALWAYS on the left side there and pedestrians (mostly) walk on the right side ... the segregation by the 2 surfaces is "stronger" for the people than the sign (and healthier) ... That's why I would also tag these parts of the way with "segregated=yes", it corresponds exactly with the situation there.

But I don't think it's a Germany specific issue ... it can happen everywhere. For example when ways were segregated in the past, then some changes took place, and on parts of the way there is no segreation anymore, and the officials decided to legally remove segregation on the COMPLETE way (to avoid splitting in small parts with different confusing signs), but people still respect the segregation where it's very visible and dominant.

Last edited 10 months ago by goodidea (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.