Modify

Opened 2 months ago

Closed 5 weeks ago

Last modified 3 weeks ago

#20293 closed defect (fixed)

Relations containing same members is not an error

Reported by: francians Owned by: team
Priority: normal Milestone: 21.02
Component: Core validator Version:
Keywords: template_report relations same members Cc: mkoniecz

Description

What steps will reproduce the problem?

  1. Create two relations with same members
  2. Add type=route+route=hiking on first
  3. Add type=route+route=bicycle on second
  4. Validate

What is the expected result?

Nothing

What happens instead?

A warning is given

Please provide any additional information below. Attach a screenshot if possible.

Often hiking and bicycle routes shares the same members. Since route="bicycle;hiking" is not accepted, you have to duplicate the relation and this shouldn't give a warning.

Thanks
Cheers,
Francesco

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Revision:17329
Build-Date:2020-11-22 02:30:52
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17329 it) Linux Arch Linux
Memory Usage: 401 MB / 3976 MB (248 MB allocated, but free)
Java version: 14.0.2+12, N/A, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: GNOME
Environment variable LANG: it_IT.UTF-8
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35640)
+ buildings_tools (35669)
+ reverter (35640)
+ turnrestrictions (35640)
+ utilsplugin2 (35674)
+ wikipedia (1.1.4)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/IT.zip
+ ${HOME}/JOSM/Presets_NewTags/Presets_NewTags-preset.xml
+ https://raw.githubusercontent.com/osmItalia/cai_josm_preset/master/cai.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1

Validator rules:
- https://josm.openstreetmap.de/josmfile?page=Rules/SuspiciousSwimming_Pool&zip=1
+ ${HOME}/git/map-this-way/MapThisWay.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/ItalySpecific&zip=1

Attachments (0)

Change History (16)

comment:1 Changed 2 months ago by skyper

I have the same problem with a bus route and two share_taxi routes, one with reservation and the other one without. All three have identical members.

Think for route relations with different route=* this warning should not be thrown.

comment:2 Changed 2 months ago by GerdP

In what case should two relations with the same members but different keys produce a warning?

comment:3 Changed 2 months ago by skyper

That is tricky and sometimes will depend on the tags.

Relations within defaultpresets which, probably, do not work with same members:

  • building
  • site
  • turn-restriction
  • lane connectivity
  • associated street
  • street
  • waterway
  • bridge
  • tunnel

All other might be ok, depending on the tags:

  • multipolygon
  • boundary
  • enforcement
  • route
  • route network
  • destination sign

Think, an informal warning should be ok and #20022 was too fast closed as e.g. a destination sign relation with same member and same destination=* is an error but same members and same tags but different values for destination is ok. Similar is true for multipolygons as a building outline with several levels as individual MPs like this sports_centre is ok but two MPs with same members but different landuse=* is an error. (Does "overlapping area" catch these cases?)

Last edited 2 months ago by skyper (previous) (diff)

comment:4 Changed 2 months ago by GerdP

Does "overlapping area" catch these cases?

It should not complain when the areas are identical.
The DuplicateRelation test is rather complex because it doesn't simply compare the members. It first collects the nodes of ways, probably to find duplicated shapes as well. I have to play with this to find out how it works in detail.

comment:5 Changed 5 weeks ago by skyper

Ticket #20422 has been marked as a duplicate of this ticket.

comment:6 Changed 5 weeks ago by skyper

Cc: mkoniecz added

comment:7 Changed 5 weeks ago by skyper

Keywords: validator bicycle hiking removed

comment:8 Changed 5 weeks ago by GerdP

I think we can simply reduce severity to info?

comment:9 Changed 5 weeks ago by mkoniecz

I think we can simply reduce severity to info?

That would be great!

comment:10 Changed 5 weeks ago by GerdP

Resolution: fixed
Status: newclosed

In 17476/josm:

fix #20293: Relations containing same members is not an error

  • lower severity

comment:11 Changed 5 weeks ago by GerdP

Milestone: 21.01

comment:12 Changed 5 weeks ago by skyper

Sorry, I did not comment, yesterday, but I think it was too fast, e.g for "duplicate relations" I get two different warnings, so this one, lower on priority, needs to be held back.

Looking at #20425, we now miss problems which should at least raise a warning (on upload).

comment:13 Changed 5 weeks ago by GerdP

I've only changed the severity for the "same members" warning, not for "duplicate relations"

comment:14 Changed 5 weeks ago by skyper

I know. The problem is the evolving tagging system and tagging styles. Some former general rules are not working anymore and we need to decide how to improve/diversify/replace them. One way is probably similar to crossing ways, e.g. diversify by type=*.

In my eyes, "duplicate relations" and "relations with same members" belong to one category and should not both be raised for the same relation. So, I took a short glance a "duplicate relations` yesterday (#20424) with your follow-up in #20425. ATM, there are errors which are missed by "duplicate relations" but not by "same members". As the default setting for upload is to not show informal warnings, they are usually not displayed anymore.

A long story short: It might be better to start from the top, making sure most errors and real problems are caught and then silencing the lower priority test.

A simply example two identical landuse mps with only one with name=*.

comment:15 Changed 5 weeks ago by GerdP

A simply example two identical landuse mps with only one with name=*

Well, question is if we want to find identical landuse polygons or just mps. My current thinking is that the whole test coded in DuplicateRelation.java is rather useless. The real problem is not when we have two identical relations but when we have two relations which mean the same object but use different members. I think we had cases like different complex MP with the name "Schwarzwald" (or was it "Bayerischer Wald"?)
Or more general : two area objects with the same name (no matter if they are MP or just closed ways. I think that might be worse a warning.

comment:16 Changed 3 weeks ago by stoecker

Milestone: 21.0121.02

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.