Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#20422 closed defect (duplicate)

"Relations with same members (1)" false positive

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report same member Cc:

Description

What steps will reproduce the problem?

  1. Have building where levels 2-6 are fully a parking
  2. create two multipolygons with the same outer
  3. run validator

What is the expected result?

No complaints

What happens instead?

"Relations with same members (1)" that will be raise forever

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-01-21 23:33:21 +0100 (Thu, 21 Jan 2021)
Revision:17474
Build-Date:2021-01-22 02:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17474 en) Linux Ubuntu 20.04.1 LTS
Memory Usage: 403 MB / 3974 MB (241 MB allocated, but free)
Java version: 11.0.9.1+1-Ubuntu-0ubuntu1.20.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Desktop environment: LXQt
Java package: openjdk-11-jre:amd64-11.0.9.1+1-0ubuntu1~20.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
Environment variable LANG: en_US.UTF-8
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
Dataset consistency test: No problems found

Plugins:
+ reverter (35688)

Attachments (0)

Change History (3)

comment:1 Changed 3 months ago by skyper

Keywords: same member added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #20293.

comment:2 in reply to:  description Changed 3 months ago by skyper

Replying to mkoniecz:

What happens instead?

"Relations with same members (1)" that will be raise forever

For now, you can add the individual error to your ignore list in order to not face again.

comment:3 Changed 3 months ago by mkoniecz

For now, you can add the individual error to your ignore list in order to not face again.

I know, but I was thinking rather about any other mapper validating this area (I am not expecting to map in this place ever again)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.