Modify

Opened 4 months ago

Last modified 3 months ago

#20287 new defect

Characters such as "+" trigger spurious validator error in brand:wikipedia

Reported by: skquinn Owned by: floscher
Priority: normal Milestone:
Component: Plugin wikipedia Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Run JOSM's validator where the check includes an element that has a tag (for example) brand:wikipedia=en:Academy Sports + Outdoors
  2. View validator error report

What is the expected result?

No error/warning (as this is the brand's Wikipedia page, and the way the company brand appears in print, with the plus sign and all)

What happens instead?

Error with "[Wiki] brand:wikipedia=* tag should not have URL-encoded values"

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Revision:17329
Build-Date:2020-11-22 02:30:52
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17329 en) Linux Ubuntu 18.04.5 LTS
Memory Usage: 542 MB / 3959 MB (80 MB allocated, but free)
Java version: 11.0.9.1+1-Ubuntu-0ubuntu1.18.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: GNOME-Classic:GNOME
Java package: openjdk-11-jre:amd64-11.0.9.1+1-0ubuntu1~18.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
Environment variable LANG: en_US.UTF-8
libcommons-compress-java: libcommons-compress-java:all-1.18-1~18.04
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (35640)
+ CADTools (1008)
+ CommandLine (35640)
+ Create_grid_of_ways (35640)
+ EasyPresets (1595741614)
+ FastDraw (35640)
+ FixAddresses (35640)
+ HouseNumberTaggingTool (35640)
+ OpeningHoursEditor (35640)
+ SimplifyArea (35640)
+ TombPlugin (58)
+ alignways (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ auto_tools (73)
+ buildings_tools (35640)
+ changeset-viewer (22)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ damn (0.2.0)
+ editgpx (35562)
+ ejml (35458)
+ fieldpapers (v0.5.0)
+ flatlaf (35589)
+ geotools (35458)
+ graphview (35640)
+ gridify (1588746833)
+ imagery_offset_db (35640)
+ jaxb (35543)
+ jna (35458)
+ josm-batch-downloader (1.0.2)
+ jts (35458)
+ livegps (35640)
+ log4j (35458)
+ mapwithai (1.7.1.1)
+ measurement (35640)
+ merge-overlap (35640)
+ michigan_left (35640)
+ opendata (35640)
+ pbf (35640)
+ poly (35640)
+ print (35640)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ reverter (35640)
+ rex (53)
+ splinex (35562)
+ tageditor (35640)
+ terracer (35640)
+ turnlanes-tagging (288)
+ turnrestrictions (35640)
+ undelete (35640)
+ utilsplugin2 (35640)
+ waypoint_search (35562)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/AdvertisingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/US.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Community_Centre&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/TurnLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Animal_facilities&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Baby_friendliness&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/WifiHotspots&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/COVID-19&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OSMRookie&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/MastAndTower&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Xmas&zip=1
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/main/dist/presets/nsi-josm-presets.min.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Schools&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NoFeature&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://github.com/MissingMaps/josm_styles/archive/master.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/Incline&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/SuspiciousSwimming_Pool&zip=1
- https://josm.openstreetmap.de/josmfile?page=Rules/KeepRight&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/MissingWeekdays&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/QAToolInspiredValidations&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/OSMLint&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/Pictures&zip=1

Last errors/warnings:
- 00065.710 W: javax.imageio.IIOException: Caught exception during read:. Cause: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
- 00065.721 E: Failed to locate image 'traffic_signs_presets/tunnel.png'
- 00065.724 W:  Tunnel: Could not get presets icon traffic_signs_presets/tunnel.png
- 00877.843 W: Could not move autosaved file MapWithAI_20201223_093612451.osm to deleted_layers folder
- 00877.844 W: Unable to delete backup file <josm.pref>/autosave/MapWithAI_20201223_093612451.osm

Attachments (0)

Change History (7)

comment:1 Changed 4 months ago by skyper

Component: CoreCore shortcuts
Priority: minornormal
Resolution: worksforme
Status: newclosed

Does already exist (Shift+A+[1–0A-Z]), see wiki:/Help/Dialog/LayerList#ActivateLayer Sorry.

Last edited 4 months ago by skyper (previous) (diff)

comment:2 Changed 4 months ago by skyper

Component: Core shortcutsPlugin wikipedia
Resolution: worksforme
Status: closedreopened

I do not get this warning, though, I do not have the wikipedia plugin installed. Does this warning come from the plugin?

comment:3 Changed 4 months ago by skyper

Owner: changed from team to skquinn
Status: reopenedneedinfo

comment:4 Changed 4 months ago by Klumbumbus

Status: needinfonew

Yes the warnings with "[Wiki]" at the begining are from the wikipedia plugin iirc.

comment:5 Changed 4 months ago by Klumbumbus

Owner: changed from skquinn to floscher

comment:6 Changed 3 months ago by skyper

Ticket #20413 has been marked as a duplicate of this ticket.

comment:7 Changed 3 months ago by skyper

Duplicate of #17832?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain floscher.
as The resolution will be set.
to The owner will be changed from floscher to the specified user.
The owner will change to skquinn
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from floscher to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.