Modify

Opened 3 months ago

Closed 3 weeks ago

#20202 closed defect (fixed)

[patch] macOS: tested build doesn't know it's tested

Reported by: Stereo Owned by: Stereo
Priority: normal Milestone: 21.02
Component: Core Version:
Keywords: template_report macOS regression Cc:

Description

What steps will reproduce the problem?

  1. Download 17329
  2. Look at the MOTD

What is the expected result?

It doesn't say 'You should update!'

What happens instead?

It says 'You should update!'

Please provide any additional information below. Attach a screenshot if possible.

I probably need to strip "Is-Local-Build:true" from the revision file again when I'm building a tested release, and can't just rely on environment variables to know I'm a tested revision.

Revision:17329
Is-Local-Build:true
Build-Date:2020-11-22 22:31:51

Identification: JOSM/1.5 (17329 SVN en_GB) Mac OS X 10.16
OS Build number: macOS 11.0.1 (20B29)
Memory Usage: 392 MB / 8192 MB (223 MB allocated, but free)
Java version: 15.0.1+9, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733632 1680x1050 (scaling 2.0x2.0)
Maximum Screen Size: 1680x1050
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [-Dapple.awt.application.appearance=system, --module-path=/Applications/JOSM.app/Contents/app/mods]

Plugins:
+ AddrInterpolation (35640)
+ CommandLine (35640)
+ Create_grid_of_ways (35640)
+ ImportImagePlugin (35567)
+ ImproveWay (29)
+ Mapillary (1.5.28-1-g937e98c)
+ OpeningHoursEditor (35640)
+ PicLayer (2a9aa7a)
+ RelationDissolve (0.2.0)
+ alignways (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ auto_tools (73)
+ buildings_tools (35640)
+ changeset-viewer (25)
+ conflation (0.6.6)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ ejml (35458)
+ flatlaf (35652)
+ geotools (35458)
+ gridify (1606242219)
+ http2 (35427)
+ imagery-xml-bounds (35640)
+ jaxb (35543)
+ jna (35458)
+ jogl (1.2.3)
+ jts (35458)
+ log4j (35458)
+ opendata (35640)
+ openqa (0.2.0)
+ poly (35640)
+ public_transport (35640)
+ reltoolbox (35640)
+ reverter (35640)
+ shrinkwrap (v1.0.4)
+ splinex (35562)
+ terracer (35640)
+ todo (30306)
+ undelete (35640)
+ utilsplugin2 (35640)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ http://osmtools.de/josm/steps.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportGtfs&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://gitlab.com/k127/josm-presets/raw/master/diplomatic.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Potlach2_access&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/IconTester&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Potlatch2&zip=1

Validator rules:
+ http://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1
+ http://www.openrailwaymap.org/validator/de-openrailwaymap.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/MissingWeekdays&zip=1
+ https://raw.githubusercontent.com/nlehuby/transport_mapcss/master/transport.validator.mapcss

Last errors/warnings:
- 00018.626 W: Not a single layer for the name 'Bing Sat': []
- 00023.848 E: <josm.userdata>/plugins/opendata/resources/org/openstreetmap/josm/plugins/opendata/modules/fr/datagouvfr/datasets/agriculture/RegistreParcellaire.mapcss (No such file or directory)

Attachments (0)

Change History (7)

comment:1 Changed 3 months ago by Stereo

Fix in #20257

comment:2 Changed 4 weeks ago by Stereo

Milestone: 21.01

comment:3 Changed 4 weeks ago by Stereo

Leaving this open for now just to check my fix.

comment:4 Changed 4 weeks ago by stoecker

Milestone: 21.0121.02

Milestone renamed

comment:5 Changed 3 weeks ago by Stereo

This is still happening. I am rewriting resources/REVISION but ant dist re-creates it by calling create-revision again.

Vincent will check how the makefile on the josm server does it - probably creating the jar by hand.

Last edited 3 weeks ago by Stereo (previous) (diff)

comment:6 Changed 3 weeks ago by Stereo

Summary: macOS: tested build doesn't know it's tested[patch] macOS: tested build doesn't know it's tested

It turns out that ant dist clobbers the resources/RELEASE file.

https://patch-diff.githubusercontent.com/raw/openstreetmap/josm/pull/69.diff adds a releasebuild parameter to the ant build.xml create-release target, and tells the github action to use that when getting triggered for a 'tested' build (ant -Dreleasebuild=true).

This hopefully is close enough to reproducing what the josm build server makefile does.

Side-by-side diff at https://github.com/openstreetmap/josm/pull/69/files

(Also did some drive-by comment cruft cleanup.)

Last edited 3 weeks ago by Stereo (previous) (diff)

comment:7 Changed 3 weeks ago by stoecker

Resolution: fixed
Status: assignedclosed

In 17493/josm:

fix #20202 - add parameter for release builds with ant

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Stereo.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.