Modify

Opened 11 days ago

Closed 10 days ago

Last modified 10 days ago

#20116 closed defect (duplicate)

Error on plugin update

Reported by: anonymous Owned by: maripogoda
Priority: normal Milestone:
Component: Plugin EasyPresets Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 7 32-Bit
OS Build number: Windows 7 Ultimate (7601)
Memory Usage: 789 MB / 989 MB (112 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366x768 (scaling 1.0x1.0), \Display1 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (35640)
+ BuildingGeneralization (23)
+ CADTools (1008)
+ ColorPlugin (1537115529)
+ CommandLine (35640)
+ Create_grid_of_ways (35640)
+ CustomizePublicTransportStop (35640)
+ DirectDownload (35640)
+ DirectUpload (35640)
+ DxfImport (1013)
+ EasyPresets (1604762161)
+ ElevationProfile (35640)
+ FastDraw (35640)
+ HouseNumberTaggingTool (35640)
+ ImageWayPoint (35640)
+ ImportImagePlugin (35567)
+ ImproveOsm (202)
+ ImproveWay (29)
+ InfoMode (35543)
+ OpenStreetCam (350)
+ OpeningHoursEditor (35640)
+ PicLayer (2a9aa7a)
+ PolygonCutOut (v0.7)
+ QuickLabel (18)
+ RelationDissolve (0.2.0)
+ RoadSigns (35640)
+ ShapeTools (1240)
+ SimplifyArea (35640)
+ Tracer-testing (1590860163)
+ Tracer2 (35640)
+ alignways (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ auto_tools (73)
+ buildings_tools (35640)
+ changeset-viewer (22)
+ colorscheme (35543)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ damn (0.2.0)
+ dataimport (35640)
+ editgpx (35562)
+ ejml (35458)
+ ext_tools (35640)
+ fieldpapers (v0.5.0)
+ geohash (79)
+ geotools (35458)
+ globalsat (35640)
+ gpsblam (35458)
+ graphview (35640)
+ gridify (1588746833)
+ imagery-xml-bounds (35640)
+ imagery_offset_db (35640)
+ importvec (35567)
+ indoor_sweepline (35640)
+ intersection (0.0.7)
+ javafx-windows (35458)
+ jaxb (35543)
+ jna (35458)
+ jts (35458)
+ junctionchecking (35640)
+ livegps (35640)
+ log4j (35458)
+ markseen (14)
+ measurement (35640)
+ merge-overlap (35640)
+ microdata_scraping (1570137897)
+ namemanager (35567)
+ opendata (35640)
+ openqa (0.2.0)
+ openvisible (35640)
+ osm-obj-info (56)
+ photo_geotagging (35640)
+ photoadjust (35640)
+ print (35640)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ public_transport (35640)
+ rasterfilters (35640)
+ reltoolbox (35640)
+ reverter (35640)
+ rex (53)
+ routes (35543)
+ routing (35640)
+ scoutsigns (169)
+ splinex (35562)
+ surveyor (35640)
+ tageditor (35640)
+ terracer (35640)
+ todo (30306)
+ tofix (490)
+ touchscreenhelper (35640)
+ turnlanes (35640)
+ turnlanes-tagging (288)
+ turnrestrictions (35640)
+ undelete (35640)
+ utilsplugin2 (35640)
+ waydownloader (35640)
+ waypoint_search (35562)
+ wikipedia (1.1.4)
+ wms-turbo-challenge2 (35562)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/UA.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/MastAndTower&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/SentieriItaliani&zip=1
+ https://raw.githubusercontent.com/igitov/forest-josm-tagging-presets/master/forest-presets.xml

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Incline&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_EUR_OR.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/PriorityRoad&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Mountains&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/QAToolInspiredValidations&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/OSMLint&zip=1

Last errors/warnings:
- 00041.150 W: Warning in tagging preset "leaf_type-Type": Ignoring 'values' attribute as 'list_entry' elements are given.
- 00070.596 E: Cannot load library rxtxSerial. If you need support to install it try Globalsat homepage at http://www.raphael-mack.de/josm-globalsat-gpx-import-plugin/
- 10276.916 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 28 >= 28
- 10280.363 W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>opendata</li><li>ShapeTools</li><li>editgpx</li><li>turnlanes-tagging</li><li>utilsplugin2</li><li>EasyPresets</li><li>namemanager</li><li>openqa</li><li>PicLayer</li><li>surveyor</li><li>ejml</li><li>tofix</li><li>Tracer-testing</li><li>ColorPlugin</li><li>ImageWayPoint</li><li>openvisible</li><li>fieldpapers</li><li>photo_geotagging</li><li>ImproveWay</li><li>apache-commons</li><li>HouseNumberTaggingTool</li><li>geotools</li><li>javafx-windows</li><li>DxfImport</li><li>public_transport</li><li>measurement</li><li>OpenStreetCam</li><li>continuosDownload</li><li>jaxb</li><li>routing</li><li>indoor_sweepline</li><li>PolygonCutOut</li><li>wikipedia</li><li>importvec</li><li>Create_grid_of_ways</li><li>jts</li><li>splinex</li><li>osm-obj-info</li><li>FastDraw</li><li>todo</li><li>markseen</li><li>waypoint_search</li><li>ImportImagePlugin</li><li>OpeningHoursEditor</li><li>areaselector</li><li>buildings_tools</li><li>Tracer2</li><li>globalsat</li><li>merge-overlap</li><li>tageditor</li><li>SimplifyArea</li><li>dataimport</li><li>microdata_scraping</li><li>alignways</li><li>routes</li><li>CADTools</li><li>geohash</li><li>intersection</li><li>AddrInterpolation</li><li>terracer</li><li>jna</li><li>contourmerge</li><li>BuildingGeneralization</li><li>rex</li><li>ElevationProfile</li><li>ImproveOsm</li><li>reverter</li><li>ext_tools</li><li>pt_assistant</li><li>touchscreenhelper</li><li>imagery-xml-bounds</li><li>undelete</li><li>RelationDissolve</li><li>waydownloader</li><li>livegps</li><li>reltoolbox</li><li>RoadSigns</li><li>wms-turbo-challenge2</li><li>scoutsigns</li><li>gridify</li><li>turnrestrictions</li><li>rasterfilters</li><li>log4j</li><li>CustomizePublicTransportStop</li><li>auto_tools</li><li>imagery_offset_db</li><li>junctionchecking</li><li>InfoMode</li><li>gpsblam</li><li>photoadjust</li><li>graphview</li><li>DirectDownload</li><li>changeset-viewer</li><li>DirectUpload</li><li>turnlanes</li><li>damn</li><li>CommandLine</li><li>print</li><li>colorscheme</li><li>QuickLabel</li><li>austriaaddresshelper</li><li>apache-http</li></ul>The plugins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: Timer-10 (871)
java.lang.ArrayIndexOutOfBoundsException: 28 >= 28
	at java.util.Vector.removeElementAt(Unknown Source)
	at javax.swing.tree.DefaultMutableTreeNode.remove(Unknown Source)
	at javax.swing.tree.DefaultMutableTreeNode.removeAllChildren(Unknown Source)
	at org.openstreetmap.josm.gui.preferences.ToolbarPreferences.loadActions(ToolbarPreferences.java:1066)
	at org.openstreetmap.josm.gui.preferences.ToolbarPreferences.getDefinedActions(ToolbarPreferences.java:1095)
	at org.openstreetmap.josm.gui.preferences.ToolbarPreferences.refreshToolbarControl(ToolbarPreferences.java:1167)
	at org.maripo.josm.easypresets.EasyPresetsPlugin$1.run(EasyPresetsPlugin.java:55)
	at java.util.TimerThread.mainLoop(Unknown Source)
	at java.util.TimerThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 11 days ago by skyper

Component: CorePlugin EasyPresets
Owner: changed from team to maripogoda

I find EasyPresets in the log.

comment:2 Changed 10 days ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20065.

comment:3 Changed 10 days ago by GerdP

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain maripogoda.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.