Modify

Opened 11 days ago

Closed 10 days ago

Last modified 8 days ago

#20115 closed defect (fixed)

Create Multipolygon: Strange relation editor entries in window menu which can lead to a stall

Reported by: skyper Owned by: team
Priority: critical Milestone: 20.11
Component: Core Version: latest
Keywords: template_report relation editor deleted layer create multipolygon Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Create Multipolygon with multipoly.show-relation-editor
  2. Close the relation editor
  3. Have mysterious relation editor entry at the bottom of the window menu
  4. Delete layer
  5. Click on relation editor entry in windows menu
  6. In the now open relation editor click on cancel
  7. In the following unsaved changes dialog click on anything

What is the expected result?

Some reaction

What happens instead?

No reaction. I cannot close the window.
Only creating more identical windows is possible and the JOSM session is unusable.

Please provide any additional information below. Attach a screenshot if possible.

I had play around with "create multipolygon" in this session and used redo/undo in different layers with possible open relation editors. I probably did even delete layers with open relation editors with unsaved changes. The relation looked like one of this relations where the layer was already deleted.

For the chance that it can help I'll attach a dump.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-18 20:16:58 +0100 (Wed, 18 Nov 2020)
Revision:17323
Build-Date:2020-11-19 02:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (1)

dump.txt (137.7 KB) - added by skyper 11 days ago.
thread dump

Download all attachments as: .zip

Change History (7)

Changed 11 days ago by skyper

Attachment: dump.txt added

thread dump

comment:1 Changed 10 days ago by GerdP

See #19966 which might well be the reason for this. If the relation editor is started in non-modal mode and opens other windows they cannot be closed normally.

comment:2 Changed 10 days ago by skyper

Description: modified (diff)
Keywords: create multipolygon added
Priority: majorcritical
Summary: Strange relation editor entries in window menu which can lead to a stallCreate Multipolygon: Strange relation editor entries in window menu which can lead to a stall

I wondered about the strange relation editor entries in windows menu, in first place. So I tried to reproduce and it is quite easy. I changed the description. This is the root cause and needs to be fixed

Replying to GerdP:

See #19966 which might well be the reason for this. If the relation editor is started in non-modal mode and opens other windows they cannot be closed normally.

I cannot follow here. Did you mix up the modes?
As of #19966, this relation editor is modal or what does the menu entry represent?

  1. Is #19966 the reason for the missing cleanup of entries in windows menu?
  2. Should not all entries tied to a data layer be removed from the windows menu if the layer is deleted?

comment:3 Changed 10 days ago by GerdP

I think ss long as #19966 isn't fixed there is no way to use the relation editor to modify the just created relation.

comment:4 Changed 10 days ago by GerdP

Resolution: fixed
Status: newclosed

In 17325/josm:

fix #19966 and #20115
don't open relation editor in modal mode

comment:5 Changed 10 days ago by GerdP

Milestone: 20.10

comment:6 Changed 8 days ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.