Modify

Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#19994 closed defect (duplicate)

JOSM can not open a gpx file

Reported by: Karzanomer@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. When I try to open a gps file. I used to do that without error in previous versions

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1803 (17134)
Memory Usage: 240 MB / 247 MB (80 MB allocated, but free)
Java version: 1.8.0_271-b09, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 3840x2160 (scaling 1.0x1.0)
Maximum Screen Size: 3840x2160
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Last errors/warnings:
- 00064.153 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 00228.132 E: Handled by bug report queue: java.time.DateTimeException: Invalid value for MonthOfYear (valid values 1 - 12): 17434
- 00248.837 E: Handled by bug report queue: java.time.DateTimeException: Invalid value for MonthOfYear (valid values 1 - 12): 17434


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (643) of main
java.time.DateTimeException: Invalid value for MonthOfYear (valid values 1 - 12): 17434
	at java.time.temporal.ValueRange.checkValidValue(Unknown Source)
	at java.time.temporal.ChronoField.checkValidValue(Unknown Source)
	at java.time.LocalDate.of(Unknown Source)
	at java.time.LocalDateTime.of(Unknown Source)
	at java.time.ZonedDateTime.of(Unknown Source)
	at org.openstreetmap.josm.tools.date.DateUtils.tsFromString(DateUtils.java:94)
	at org.openstreetmap.josm.io.GpxReader$Parser.endElement(GpxReader.java:478)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(Unknown Source)
	at org.openstreetmap.josm.tools.XmlUtils.parseSafeSAX(XmlUtils.java:123)
	at org.openstreetmap.josm.io.GpxReader.parse(GpxReader.java:642)
	at org.openstreetmap.josm.gui.io.importexport.GpxImporter.importData(GpxImporter.java:125)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:98)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:370)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:320)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 15 months ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19914.

comment:2 Changed 15 months ago by Klumbumbus

Which application cretaed the gpx file?
Could you please attach the gpx file?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.