Modify

Opened 5 weeks ago

Closed 3 weeks ago

Last modified 4 days ago

#19995 closed defect (fixed)

[Patch] exit saving two layers (without upload) not possible

Reported by: leni Owned by: Don-vip
Priority: normal Milestone: 20.11
Component: Core Version:
Keywords: template_report upload save Cc: DevCharly, simon04

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. I have two layers, with data modified.
  2. I leave josm ctrl+Q
  3. josm proposes to upload the two layers:


  1. I don't want to upload, I want to save; I remove upload from the 1st layer:


  1. I click on save on the 1st layer

What is the expected result?

save the 1st layer selected

What happens instead?

josm adds send and save:

I do not select only save

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 729 MB / 1751 MB (118 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.formdev.flatlaf.FlatLightLaf
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35499)
+ apache-commons (35524)
+ apache-http (35092)
+ buildings_tools (35563)
+ cadastre-fr (35539)
+ changeset-viewer (22)
+ conflation (0.6.6)
+ ejml (35313)
+ flatlaf (35541)
+ geotools (35169)
+ imagery_offset_db (35405)
+ javafx-windows (35458)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ measurement (35405)
+ opendata (35513)
+ photo_geotagging (35499)
+ photoadjust (35405)
+ reverter (35556)
+ scripting (30798)
+ shrinkwrap (v1.0.3)
+ tageditor (35258)
+ todo (30306)
+ utilsplugin2 (35487)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1

Validator rules:
+ https://raw.githubusercontent.com/nlehuby/transport_mapcss/master/transport.validator.mapcss

Last errors/warnings:
- 00010.840 W: Warning: Failed to scan file 'fr.toulouse.jar' for module information. Skipping.

Attachments (6)

josm2layers01.png (26.0 KB) - added by leni 5 weeks ago.
josm2layers02.png (25.7 KB) - added by leni 5 weeks ago.
josm2layers03.png (27.0 KB) - added by leni 5 weeks ago.
19995_worksforme.png (17.1 KB) - added by Don-vip 5 weeks ago.
josm2layers20201025.mp4 (1.8 MB) - added by leni 5 weeks ago.
JOSM-save-layers-actions.diff (1.7 KB) - added by DevCharly 3 weeks ago.

Download all attachments as: .zip

Change History (19)

Changed 5 weeks ago by leni

Attachment: josm2layers01.png added

Changed 5 weeks ago by leni

Attachment: josm2layers02.png added

Changed 5 weeks ago by leni

Attachment: josm2layers03.png added

comment:1 Changed 5 weeks ago by Don-vip

Description: modified (diff)
Keywords: upload save added

Changed 5 weeks ago by Don-vip

Attachment: 19995_worksforme.png added

comment:2 Changed 5 weeks ago by Don-vip

Owner: changed from team to leni
Status: newneedinfo

Can't reproduce with r17265, works as expected:


Are you sure you didn't click on Upload by inadvertence? If yes please try with latest to see if it's fixed.

Changed 5 weeks ago by leni

Attachment: josm2layers20201025.mp4 added

comment:3 in reply to:  2 Changed 5 weeks ago by leni

Replying to Don-vip:

Are you sure you didn't click on Upload by inadvertence? If yes please try with latest to see if it's fixed.

same result without sending, I send a josm2layers20201025.mp4 video, after starting latest

comment:4 Changed 5 weeks ago by leni

Resolution: irreproducible
Status: needinfoclosed

I have renamed preferences.xml and I have no more problem.

comment:5 Changed 5 weeks ago by leni

Component: CorePlugin flatlaf
Resolution: irreproducible
Status: closedreopened

I have the problem with the FlatLaf plugin, and everything is ok when I take it out.

comment:6 Changed 5 weeks ago by Klumbumbus

Cc: DevCharly simon04 added
Owner: changed from leni to team
Status: reopenednew

Changed 3 weeks ago by DevCharly

comment:7 Changed 3 weeks ago by DevCharly

I've attached a patch that fixes the issue: attachment:JOSM-save-layers-actions.diff

The problem is that the cell renderer and editor use the same instance.

The checkboxes are updated when starting editing first row.
Then the second row is painted and the checkboxes are updated again with values from second row.
Then editing first row finishes and gets wrong checkbox values (from renderer).

The patch uses separate instances for the cell renderer and the editor.

This is the same change done 4 years ago for the first column in save dialog:
https://josm.openstreetmap.de/changeset/9754/josm

IMHO it was luck that it worked with Windows and other Lafs.
A possible reason could be that in FlatLaf the table grid lines are hidden and
cell interspacing is zero. Maybe this triggers a repaint of second row when editing first row...
Other Lafs show grid lines and have one pixel space between cells.

comment:8 Changed 3 weeks ago by Don-vip

Component: Plugin flatlafCore
Milestone: 20.10
Owner: changed from team to Don-vip
Status: newassigned

comment:9 Changed 3 weeks ago by Don-vip

Summary: exit saving two layers (without upload) not possible[Patch] exit saving two layers (without upload) not possible

comment:10 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17308/josm:

fix #19995 - upload dialog: separate instances for cell renderer and editor (patch by DevCharly, modified)

comment:11 Changed 3 weeks ago by Don-vip

Thanks!

comment:12 Changed 8 days ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

comment:13 Changed 4 days ago by leni

thank you for the fix

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.