Modify

#19921 closed defect (duplicate)

Parallel way tool length display is broken with version 17084

Reported by: ff5722 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by ff5722)

What steps will reproduce the problem?

  1. Use the parallel ways tool

What is the expected result?

The length display will show the offset used for the parallel way tool

What happens instead?

The length display flickers between the way length and the offset length

Please provide any additional information below. Attach a screenshot if possible.

https://josm.openstreetmap.de/raw-attachment/ticket/19921/image_2020-10-12_174549.png

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 1247 MB / 2709 MB (196 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0), \Display1 1080x1920 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1920
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (35405)
+ FastDraw (35499)
+ apache-commons (35524)
+ apache-http (35092)
+ buildings_tools (35574)
+ ejml (35313)
+ geotools (35169)
+ gridify (1588746833)
+ importvec (35499)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ mapwithai-dev (1.5.5-192-g9d87fe5)
+ opendata (35513)
+ reverter (35556)
+ terracer (35560)
+ utilsplugin2 (35487)

Tagging presets:
+ E:\Nextcloud\Documents\Openstreetmap\JOSM presets\CellTower.xml
+ E:\Nextcloud\Documents\Openstreetmap\JOSM presets\motorway_link.xml
+ E:\Nextcloud\Documents\Openstreetmap\JOSM presets\TunnelLayerPreset.xml
+ E:\Nextcloud\Documents\Openstreetmap\JOSM presets\BridgeLayerPreset.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1

Last errors/warnings:
- 00616.543 W: JOSM expected to find primitive [way -102508] in dataset but it is not there. Please report this at https://josm.openstreetmap.de. This is not a critical error, it should be safe to continue in your work.
- 00616.546 E: java.lang.Exception
- 00623.607 W: JOSM expected to find primitive [way -102509] in dataset but it is not there. Please report this at https://josm.openstreetmap.de. This is not a critical error, it should be safe to continue in your work.
- 00623.608 E: java.lang.Exception
- 00694.686 W: JOSM expected to find primitive [way -102510] in dataset but it is not there. Please report this at https://josm.openstreetmap.de. This is not a critical error, it should be safe to continue in your work.
- 00694.687 E: java.lang.Exception
- 00699.111 W: JOSM expected to find primitive [way -102511] in dataset but it is not there. Please report this at https://josm.openstreetmap.de. This is not a critical error, it should be safe to continue in your work.
- 00699.112 E: java.lang.Exception

Attachments (2)

Change History (4)

Changed 19 months ago by ff5722

Changed 19 months ago by ff5722

Attachment: image_2020-10-12_174549.png added

comment:1 Changed 19 months ago by ff5722

Description: modified (diff)

comment:2 Changed 19 months ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19887.
Try r17108, see #19887.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.