Modify

Opened 16 months ago

Closed 16 months ago

Last modified 12 months ago

#19920 closed defect (fixed)

[Patch] Cancel doesn't work with "Download All Children"

Reported by: GerdP Owned by: team
Priority: normal Milestone: 20.11
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. download a complex relation without relation members, e.g. r6483867
  2. edit it in relation editor
  3. choose tab "Child Relations", note that button "Download All Children" is activated although this relation has no child relations
  4. hover over the button and see tooltip "download all child relations (recursively)
  5. click and see lots of "Fetching a package of nodes ..." messages
  6. Click on cancel

What is the expected result?

3+4: button text and tooltip should not conflict. Not sure if we need this button at all.
6: download should stop

What happens instead?

confusing texts, download doesn't stop and takes quite long

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 1501 MB / 3641 MB (302 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-XX:StartFlightRecording=name=MyRecording2,settings=d:\dbg\gerd.jfc, -XX:FlightRecorderOptions=defaultrecording=true,dumponexit=true,dumponexitpath=e:\ld\perf_20201012_172736.jfr]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35414)
+ PolygonCutOut (v0.7)
+ apache-commons (35524)
+ buildings_tools (35574)
+ continuosDownload (91)
+ ejml (35313)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ merge-overlap (35248)
+ o5m (35248)
+ opendata (35513)
+ pbf (35446)
+ poly (35248)
+ reverter (35556)
+ undelete (35521)
+ utilsplugin2 (35487)

Map paint styles:
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1

Attachments (1)

19920.patch (2.6 KB) - added by GerdP 16 months ago.

Download all attachments as: .zip

Change History (17)

Changed 16 months ago by GerdP

Attachment: 19920.patch added

comment:1 Changed 16 months ago by GerdP

Milestone: 20.10
Summary: Cancel doesn't work with "Download All Children"[Patch] Cancel doesn't work with "Download All Children"

Patch also improves performance for very complex relations.
I do not yet understand why cancel works in many other situations but not in this particular case.

comment:2 Changed 16 months ago by skyper

Download parent objects suffers the same issue.

comment:3 Changed 16 months ago by GerdP

Did not find a relation where this matters. Please tell me one.

comment:4 in reply to:  3 Changed 16 months ago by skyper

Replying to GerdP:

Did not find a relation where this matters. Please tell me one.

Sorry, I am talking about the core action "Download parent objects". This has nothing to do with relations, directly.

comment:5 Changed 16 months ago by GerdP

And what issue is there with "Download parent objects"?

comment:6 in reply to:  5 ; Changed 16 months ago by skyper

Replying to GerdP:

And what issue is there with "Download parent objects"?

Not sure, I cannot reproduce with latest, anymore. Maybe, some problem when connection is slow and/or bad. Try to open a new ticket once I face it again.

comment:7 Changed 16 months ago by GerdP

In 17202/josm:

see #19920: Cancel doesn't work with "Download All Children"

  • let Cancel call MultiFetchServerObjectReader.cancel() instead of OsmApi.getOsmApi().cancel();
  • only download child relations

comment:8 Changed 16 months ago by GerdP

Resolution: fixed
Status: newclosed

I've openend a new ticket for the remaining GUI problems, see #19938

comment:9 Changed 14 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

comment:10 Changed 13 months ago by farin2

I've just downloaded something from Overpass API from inside JOSM. The "Fetching a package of nodes ..." dialog is now already there for 15 minutes and I'm stopping to believe it will ever end.
Shall I kill java?

comment:11 Changed 13 months ago by GerdP

How is your message related to this ticket?

comment:12 in reply to:  11 Changed 13 months ago by farin2

Replying to GerdP:

How is your message related to this ticket?

GerdP (above):

click and see lots of "Fetching a package of nodes ..." messages
Click on cancel

Cancel doesn't work with "Fetching a package of nodes ..."

comment:13 Changed 13 months ago by GerdP

OK, If you can reproduce please open a new ticket describing exactly what you download.

comment:14 in reply to:  6 Changed 12 months ago by skyper

Replying to skyper:

Replying to GerdP:

And what issue is there with "Download parent objects"?

Not sure, I cannot reproduce with latest, anymore. Maybe, some problem when connection is slow and/or bad. Try to open a new ticket once I face it again.

It is back again, with a slow and unstable internet connection, see #20416.

comment:15 Changed 12 months ago by GerdP

How is it related? Ticket #20416 is not about the "Download all children" button. These are two very different functions.

comment:16 in reply to:  15 Changed 12 months ago by skyper

Replying to GerdP:

How is it related? Ticket #20416 is not about the "Download all children" button. These are two very different functions.

Sorry, I mixed this all up, you are right. Thought, we have an old ticket about canceling "Download members" but I did not find it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.