Modify

#19870 closed defect (duplicate)

Bug

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Build-Date:2020-09-07 01:30:48
Revision:17013
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17013 pt_BR) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 867 MB / 1820 MB (646 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ apache-commons (35524)
+ ejml (35313)
+ geotools (35169)
+ imagery_offset_db (35405)
+ jaxb (35092)
+ jts (35122)
+ opendata (35513)
+ turnrestrictions (35515)
+ utilsplugin2 (35487)

Last errors/warnings:
- 01151,685 W: Não é possível excluir o arquivo <josm.pref>\autosave\Cristalândia do Piauí.osm_20201001_065618449.pid
- 01233,236 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=5558063707 version=1 V lat=-10.6545822,lon=-45.1783669}


=== REPORTED CRASH DATA ===
SharpAngles#visit:
 - way: {Way id=580668070 version=2 VT nodes=[{Node id=5558063710 version=1 V lat=-10.6550028,lon=-45.1778032}, {Node id=5558063709 version=1 V lat=-10.6549196,lon=-45.177978}, {Node id=5558063708 version=1 V lat=-10.6547535,lon=-45.1781443}, {Node id=5558063707 version=1 V lat=-10.6545822,lon=-45.1783669}, {Node id=5558063706 version=1 V lat=-10.6545137,lon=-45.1785466}, {Node id=5558063705 version=1 V lat=-10.6544688,lon=-45.1783964}, {Node id=5558063704 version=1 V lat=-10.6543107,lon=-45.1782677}, {Node id=5558063703 version=1 V lat=-10.6541381,lon=-45.1779853}]}

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (54) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=5558063707 version=1 V lat=-10.6545822,lon=-45.1783669}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDatasetNotReadOnly(OsmPrimitive.java:208)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.addReferrer(OsmPrimitive.java:702)
	at org.openstreetmap.josm.data.osm.Way.addNode(Way.java:403)
	at org.openstreetmap.josm.data.osm.WaySegment.toWay(WaySegment.java:79)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.processSharpAngleForErrorCreation(SharpAngles.java:107)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.checkAngle(SharpAngles.java:100)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.checkWayForSharpAngles(SharpAngles.java:81)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.visit(SharpAngles.java:51)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:177)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:216)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:169)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 21 months ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19869.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.