Modify

Opened 8 weeks ago

Closed 7 weeks ago

Last modified 31 hours ago

#19871 closed defect (fixed)

TurnrestrictionTest cannot cope with read-only datasets.

Reported by: GerdP Owned by: team
Priority: normal Milestone: 20.11
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. add locked='true' to core\nodist\data\restriction.osm
  2. load file
  3. run validator

What is the expected result?

same as without the locked='true'

What happens instead?

bug report

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Build-Date:2020-09-07 01:30:48
Revision:17013
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17013 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 1080 MB / 3641 MB (799 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-XX:StartFlightRecording=name=MyRecording2,settings=d:\dbg\gerd.jfc, -XX:FlightRecorderOptions=defaultrecording=true,dumponexit=true,dumponexitpath=e:\ld\perf_20201001_154459.jfr]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35414)
+ PolygonCutOut (v0.7)
+ apache-commons (35524)
+ buildings_tools (35563)
+ continuosDownload (91)
+ ejml (35313)
+ geotools (35169)
+ gridify (1588746833)
+ jaxb (35092)
+ jts (35122)
+ merge-overlap (35248)
+ o5m (35248)
+ opendata (35513)
+ pbf (35446)
+ poly (35248)
+ reverter (35556)
+ terracer (35560)
+ undelete (35521)
+ utilsplugin2 (35487)

Last errors/warnings:
- 00022.639 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=-114254 version=0 MV lat=51.11969492251,lon=14.15648362716}


=== REPORTED CRASH DATA ===
SharpAngles#visit:
 - way: {Way id=-139086 version=0 MVT nodes=[{Node id=-114252 version=0 MV lat=51.11907177664,lon=14.15604930116}, {Node id=-114254 version=0 MV lat=51.11969492251,lon=14.15648362716}, {Node id=-114257 version=0 MV lat=51.11989452214,lon=14.1575151514}, {Node id=-114252 version=0 MV lat=51.11907177664,lon=14.15604930116}]}

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (56) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=-114254 version=0 MV lat=51.11969492251,lon=14.15648362716}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDatasetNotReadOnly(OsmPrimitive.java:208)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.addReferrer(OsmPrimitive.java:702)
	at org.openstreetmap.josm.data.osm.Way.addNode(Way.java:403)
	at org.openstreetmap.josm.data.osm.WaySegment.toWay(WaySegment.java:79)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.processSharpAngleForErrorCreation(SharpAngles.java:107)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.checkAngle(SharpAngles.java:100)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.checkWayForSharpAngles(SharpAngles.java:81)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.visit(SharpAngles.java:51)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:177)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:216)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:169)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (2)

19871.patch (1.8 KB) - added by GerdP 8 weeks ago.
19871.2.patch (2.8 KB) - added by GerdP 8 weeks ago.
remove also now obsolete code to handle one-node-ways

Download all attachments as: .zip

Change History (5)

Changed 8 weeks ago by GerdP

Attachment: 19871.patch added

comment:1 Changed 8 weeks ago by GerdP

The patch also fixes a memory leak caused by the old implementation (each validation added the "pseudoWay" as a referrer to the via node.

Changed 8 weeks ago by GerdP

Attachment: 19871.2.patch added

remove also now obsolete code to handle one-node-ways

comment:2 Changed 7 weeks ago by GerdP

Resolution: fixed
Status: newclosed

In 17098/josm:

fix #19871: TurnrestrictionTest cannot cope with read-only datasets.
Don't add temporary way for test

comment:3 Changed 31 hours ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.