Modify

Opened 8 weeks ago

Closed 7 weeks ago

Last modified 30 hours ago

#19869 closed defect (fixed)

test SharpAngles cannot cope with read-only datasets.

Reported by: anonymous Owned by: GerdP
Priority: normal Milestone: 20.11
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. Have sharp angle in a locked dataset

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Build-Date:2020-09-07 01:30:48
Revision:17013
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17013 pt_BR) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 880 MB / 1820 MB (246 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ apache-commons (35524)
+ ejml (35313)
+ geotools (35169)
+ imagery_offset_db (35405)
+ jaxb (35092)
+ jts (35122)
+ opendata (35513)
+ turnrestrictions (35515)
+ utilsplugin2 (35487)

Last errors/warnings:
- 00067,593 W: java.nio.file.FileSystemException: %UserProfile%\AppData\Local\Temp\josm_exec_powershell_7583410223159975057.txt: O arquivo já está sendo usado por outro processo.
- 00067,600 W: Unable to request certificate of https://grca.nat.gov.tw
- 00337,324 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=5558063707 version=1 V lat=-10.6545822,lon=-45.1783669}


=== REPORTED CRASH DATA ===
SharpAngles#visit:
 - way: {Way id=580668070 version=2 VT nodes=[{Node id=5558063710 version=1 V lat=-10.6550028,lon=-45.1778032}, {Node id=5558063709 version=1 V lat=-10.6549196,lon=-45.177978}, {Node id=5558063708 version=1 V lat=-10.6547535,lon=-45.1781443}, {Node id=5558063707 version=1 V lat=-10.6545822,lon=-45.1783669}, {Node id=5558063706 version=1 V lat=-10.6545137,lon=-45.1785466}, {Node id=5558063705 version=1 V lat=-10.6544688,lon=-45.1783964}, {Node id=5558063704 version=1 V lat=-10.6543107,lon=-45.1782677}, {Node id=5558063703 version=1 V lat=-10.6541381,lon=-45.1779853}]}

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (52) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=5558063707 version=1 V lat=-10.6545822,lon=-45.1783669}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDatasetNotReadOnly(OsmPrimitive.java:208)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.addReferrer(OsmPrimitive.java:702)
	at org.openstreetmap.josm.data.osm.Way.addNode(Way.java:403)
	at org.openstreetmap.josm.data.osm.WaySegment.toWay(WaySegment.java:79)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.processSharpAngleForErrorCreation(SharpAngles.java:107)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.checkAngle(SharpAngles.java:100)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.checkWayForSharpAngles(SharpAngles.java:81)
	at org.openstreetmap.josm.data.validation.tests.SharpAngles.visit(SharpAngles.java:51)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:177)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:216)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:169)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (1)

19869.patch (1021 bytes) - added by GerdP 8 weeks ago.
avoid to create way in sharp angles test

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 weeks ago by GerdP

Seems the validator test SharpAngles cannot cope with read-only datasets.
As a work-around you may disable this test.

comment:2 Changed 8 weeks ago by GerdP

Ticket #19870 has been marked as a duplicate of this ticket.

Changed 8 weeks ago by GerdP

Attachment: 19869.patch added

avoid to create way in sharp angles test

comment:3 Changed 8 weeks ago by GerdP

Owner: changed from team to GerdP
Status: newassigned

comment:4 Changed 8 weeks ago by GerdP

@team: OK to commit this small patch for before release?

comment:5 Changed 8 weeks ago by GerdP

Milestone: 20.10

Just noticed that we have similar problems in other tests, e.g. TurnrestrictionTest

Build-Date:2020-10-01 14:09:08
Revision:17080
Is-Local-Build:true

Identification: JOSM/1.5 (17080 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 1489 MB / 3641 MB (1329 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:53925, -ea, -Dfile.encoding=UTF-8]
Program arguments: [--debug]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35414)
+ PolygonCutOut (v0.7)
+ apache-commons (35524)
+ buildings_tools (35563)
+ continuosDownload (91)
+ ejml (35313)
+ geotools (35169)
+ gridify (1588746833)
+ jaxb (35092)
+ jts (35122)
+ merge-overlap (35248)
+ o5m (35248)
+ opendata (35513)
+ pbf (35446)
+ poly (35248)
+ reverter (35556)
+ terracer (35560)
+ undelete (35521)
+ utilsplugin2 (35487)

Last errors/warnings:
- 00515.602 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=70674930 version=11 V lat=52.9167604,lon=8.4537677}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=70674930 version=11 V lat=52.9167604,lon=8.4537677}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDatasetNotReadOnly(OsmPrimitive.java:208)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.addReferrer(OsmPrimitive.java:702)
	at org.openstreetmap.josm.data.osm.Way.addNode(Way.java:403)
	at org.openstreetmap.josm.data.validation.tests.TurnrestrictionTest.visit(TurnrestrictionTest.java:260)
	at org.openstreetmap.josm.data.osm.Relation.accept(Relation.java:176)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:216)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:169)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

comment:6 Changed 8 weeks ago by GerdP

Component: CoreCore validator
Description: modified (diff)
Summary: Bugtest SharpAngles cannot cope with read-only datasets.

comment:7 Changed 7 weeks ago by GerdP

Resolution: fixed
Status: assignedclosed

In 17100/josm:

fix #19869: test SharpAngles cannot cope with read-only datasets.
Don't use WaySegment.toWay() to calculate segment length as it adds a parent Way to existing nodes

comment:8 Changed 30 hours ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.