Modify

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 10 days ago

#19862 closed defect (fixed)

Warning "foot=yes is unnecessary for highway=footway" is incorrect

Reported by: SomeoneElse2 Owned by: team
Priority: normal Milestone: 20.10
Component: Core validator Version:
Keywords: unnecessary access tag Cc:

Description

I've just run the JOSM validator on an area including https://www.openstreetmap.org/way/757988391/history and it has warned "foot=yes is unnecessary for highway=footway" .

This is wrong, as in this area (North York Moors, England) "foot=yes" is _not_ the default - a footway across private land in the area would by default be private unless:

o access is permissive, in which case "foot=permissive" would be the correct tag

o it's CROW Act access land, in which case "foot=yes" is best tagged explicitly (this is actually the case here but the access land boundary isn't well signposted)

o it's a designated "public_footpath" or similar.

In countries with "allemansrätten" or equivalent I can somewhat see the logic, but even then removing tags that another mapper has explicitly added seems like a bad idea.

Problem first spotted due to changes in https://www.openstreetmap.org/changeset/79116201 .

JOSM version 17013, downloaded just now.

Attachments (0)

Change History (19)

comment:1 Changed 3 weeks ago by skyper

Component: CoreCore validator
Keywords: unnecessary access tag added

You are talking about a path with surface=dirt inside a national park, right. Is footway the proper highway value?
It does not make sense, in my eyes, to change the implied foot=designated to foot=yes, only, without any other restriction.

Think this special situation needs to be tagged in a different way or the warning should simply be ignored.

comment:2 Changed 3 weeks ago by SomeoneElse2

Is footway the proper highway value?

Yes. There's no public multimodal access here (I've seen no evidence of horse or cycle use). It's used by the local farmers to get to sheep via quadbike and by walker to get between the pub and the former railway.

It does not make sense, in my eyes, to change the implied foot=designated to foot=yes, only, without any other restriction.

"foot=designated" just means "designated ways are intended to be usable for the designated purpose(s)" as per https://wiki.openstreetmap.org/wiki/Tag:access%3Ddesignated . It's meaningless for a highway=footway, where it can be assumed that foot use is indended. "designated" is usually used instead of "yes", but that does mean that there is no way of saying that both "foot=permissive" and "foot=designated", which would otherwise be a perfectly reasonable combination. In the absence of an allemansrätten or similar it's extrememly important to know where there is a legal right of access that cannot easily be withdrawn and where you are similar tolerated (for now).

Incidentally https://www.openstreetmap.org/way/759870454/history shows the removal of a "foot=designated" in the same changeset. I can't comment on that one in more detail because I'm not familiar with that particular way.

Think this special situation needs to be tagged in a different way

What do you suggest?

or the warning should simply be ignored.

That's a possibility, of course, but wouldn't it make sense to not give the warning at all if it can always be ignored?

comment:3 Changed 3 weeks ago by skyper

So, there is no direct restriction about horses and vehicles at all?

I would at least add a "access=permissive" and a "FIXME=recheck access". Depending on the width of the way, personally I would choose path or track with proper access tags and sac_scale.

It is your choice to ignore warnings. This warning makes sense for many cases but maybe GB-tagging is different here. Then this warning could be silenced for some countries.

comment:4 Changed 3 weeks ago by SomeoneElse2

So, there is no direct restriction about horses and vehicles at all?

There is - it's private. Everywhere in England and Wales is private to all modes of transport unless it's a public road (tehcnically - is on the "list of streets" maintained by the local council), is a public right of way for that mode (e.g. a "public_footpath" implies right of foot access), or is open access land designated by the CROW act https://en.wikipedia.org/wiki/Countryside_and_Rights_of_Way_Act_2000 , or is permissive (the landowner tolerates access).

The foot access here is not permissive - it's a legal right via, in this case, the CROW act.

"path" doesn't really add any value, and would make the situation more complicated because there are now two things we'd need to store in the "foot" key - "designated" (saying that this path is designed for use on foot) and "yes" (saying that there is a legal right of access here, because it's on CROW act land).

"track" does make sense for https://www.openstreetmap.org/way/132409036 just to the east, because that's used for (private) motor vehicle access to the fields behind the pub, but not for this bit.

comment:5 Changed 3 weeks ago by skyper

I do not think that you can express it that way, as designated is simply an access tag. It is not easy to express the law one by one with access tags. Sometimes even the authority does not even have a clue about it see: users:Germany - vehicle=destination auf Fahrradstraßen ?.

In Germany, I would definitely use highway=path and in my area access=private, foot=yes.

comment:6 Changed 3 weeks ago by stoecker

Resolution: invalid
Status: newclosed

The highway=footway implies foot=designated. "designated ways are intended to be usable for the designated purpose(s)." So the designated implies a yes. As the text in wiki further explains that does not include access tags, which must be set individually when access is not permitted.

The validator is thus according to OSM guidelines. If you are not happy with this discuss it in the appropriate places, not the JOSM bug tracker.

See
osmwiki:Tag:highway%3Dfootway
osmwiki:Tag:foot%3Ddesignated

comment:7 Changed 3 weeks ago by SomeoneElse2

I think that we're getting a bit diverted by designated here ("so the designated implies a yes" is incorrect, but irrelevant here). For the avoidance of doubt, the JOSM validator is proposing to remove "foot=yes" from https://www.openstreetmap.org/way/757988391/history - designated is not a factor in this example.

As the main https://wiki.openstreetmap.org/wiki/Key:access makes clear, "Access values describe legal permissions/restrictions". "foot=yes" does _not_ mean that a way is physically accessible, but that it is legally accessible. In places where the default is _not_ yes it is important to record what the access permission actually is. JOSM suggesting that those tags can be removed (even by just giving a "warning") is in error in those places where there is no default right of access.

Please don't let mappers trusting JOSM's advice trash carefully recorded access information in England and Wales - we don't want to have to have a JOSM equivalent of https://wiki.openstreetmap.org/wiki/ID/Controversial_Decisions !

comment:8 Changed 3 weeks ago by SK53.osm@…

Can I just add such validator rules may seriously compromise the work of the National Trust in England, Wales & Northern Ireland. They are one of the 3 or 4 largest landowners in the United Kingdom & are using OSM to document *ALL* paths, tracks and roads on their land. They presented at SotM in Heidelberg, and have discussed their approach and tagging guidelines with OSM-UK and the broader UK OSM community. Some of us have participated in workshops with NT Staff & volunteers. Their tagging approach is well documented both in slides presented at the 2019 OSM-UK AGM, and SotM-19, but also on the wiki.

I've been concerned for some time about a similar validation rule reported by Osmose within Vespucci.

Note the usage of highway=footway and highway=path may not be the same in every country. In particular note Richard Fairhurst's strictures about problems with highway=path: these are particularly germane in England & Wales because of the legal situation described by SomeoneElse. In general serious mappers of countryside footpaths tend to use highway=footway rather than highway=path. This usage also is the original, historical usage on OSM.

Also the meaning of foot=designated in the UK is obscure. In very, very few places are pedestrians required in law to use a specific path. Pedestrians are legally allowed on more-or-less the entirety of the public highway system other than motorways.
Prior to the use of the designation tag, some mappers used foot=designated for public rights of way. For paths on private land (whether with permissive usage or otherwise) it is possible that pedestrians are required to use such paths. As SomeoneElse says this creates a conflict in the use of the foot=* tag for access. Broadly speaking multiple uses of foot=designated mean than very little can be inferred from the tag in the UK, but it also has little value because of generic legal permissions.

comment:9 Changed 3 weeks ago by stoecker

As said, discuss your issues at the correct places for tagging, not the JOSM bug tracker.

Anyway your texts sound like you want to redefine the meaning of tags and say that there is a different "default" in your country. Sorry, but this total bullshit and JOSM will not support this. Tagging must have identical meaning allover the world. There will be differences, e.g. street classes will vary in the world and whats a path in Germany can be a major road in Africa, but there cannot be a differing meaning for the same tags - that would make a common database impossible.

comment:10 Changed 3 weeks ago by anonymous

Sorry, but this total bullshit

There is no need for that language. We ought to be able to discuss things without reducing ourselves to the level of a US presidential debate.

Tagging must have identical meaning all over the world

That is, indeed, an excellent goal. This ticket, however, is not about that - it is about JOSM suggesting to mappers that tags which have a clear meaning should be removed. I refer you to https://wiki.openstreetmap.org/wiki/Key:foot which says "Legal access restriction for pedestrians" and for values points to https://wiki.openstreetmap.org/wiki/Key:access . That says against "yes" "The public has an official, legally-enshrined right of access; i.e., it's a right of way". The wiki really could not be clearer here.

comment:11 Changed 3 weeks ago by SomeoneElse2

(the last was comment by me)

comment:12 Changed 12 days ago by multimodaal

I fully agree with SomeoneElse2:

This "validator rule" is based on misconceptions of OSM-definitions and is harmful to correct OSM-entries, especially since with the "auto-fix" option it becomes a form of automated edit deleting valid data.

One of the misconceptions is seem to be that "foot=yes" means the same as "you may walk here", but foot=yes has a specific legal meaning in OSM ("The public has an official, legally-enshrined right of access; i.e., it's a right of way.") , different from foot=permissive ("Open to general traffic until such time as the owner revokes the permission which they are legally allowed to do at any time in the future")..

Just like in the UK, for the Netherlands the key foot=* and (bicycle=* on cycleways) contains information on the legal basis of the access that is granted to the general public. The legal default in the netherlands is not foot=yes, but foot=permissive.

And beside legal nuances:
furthermore highway=footway is also used -within the definitions on the OSM wiki- for marked ways that are not open to the general public but only to a specific group of pedestrians, such as customers.

Just like the main OSM-access-wiki illustrates:
"For example, to distinguish a footway with open access from one with private access, use tags like foot=yes."

Several renderers also use these explicit access-tags to indicate that it has been established that a way is actually open to the general public (when left empty you can only hope that the situation in the field is simular to some presumed default)

The suggestion to ignore the warnings doesn't help at all, because it only takes only one unknowing mapper that uses "fix" in JOSM to delete many valid entries.

So please revert this validator rules (also for cycleway/bicycle=yes, could be permissive as well) with high preference and repair the damage that was caused by it, thx!

comment:13 Changed 12 days ago by Klumbumbus

Resolution: invalidfixed

In 17147/josm:

fix #19862, see #9257 - Remove controversial warning about unnecessary foot|bicycle=yes|designated together with highway=footway|pedestrian|cycleway

comment:14 Changed 12 days ago by Klumbumbus

Milestone: 20.10

comment:15 Changed 12 days ago by Klumbumbus

Ticket #19475 has been marked as a duplicate of this ticket.

comment:16 Changed 11 days ago by SomeoneElse2

Brilliant, thanks!

comment:17 in reply to:  13 ; Changed 11 days ago by stoecker

Replying to Klumbumbus:

In 17147/josm:

fix #19862, see #9257 - Remove controversial warning about unnecessary foot|bicycle=yes|designated together with highway=footway|pedestrian|cycleway

You think it is a good idea to encourage people to enter data which obviously is incompatible to the rest of the world?

comment:18 Changed 11 days ago by multimodaal

Thanks Klumbumbus!

@stoecker:
in comment 6 you wrote :

The highway=footway implies foot=designated. 
"designated ways are intended to be usable for the designated purpose(s)." 
So the designated implies a yes

This seems central in your argument, but the inference in the last sentence is incorrect.
As stated multiple times above: "yes" in terms of OSM-access has a specific legal meaning.
If a way is designated ("intended to be usable") for walking that does not necessarily mean that all pedestrians also have an official, legally-enshrined right of access.

Foot=yes does not mean "some people may walk here" but it means:
"The public has an official, legally-enshrined right of access; i.e., it's a right of way." (in the wiki for Key:access since 2006)

On a footway "foot=" can have other values besides "yes", such as "permissive" (also in the wiki Key:access as a different value from "yes" since 2006, or even more restrictive values for footways in areas that are not open to the general public

If the OSM-definition for "footway" would be
"only for designated footways on which the public has an official, legally-enshrined right of access / right of way" (and we also would all be consistently be using a different value like "highway=path" for ways where a right of way was not established), you would have a valid point. But unfortunately this is not the case and we can not change the meaning of existing tags to the way we might think they should be. So in the current scheme of highway and access additional access-tags to highway=footway etc do give extra information that mappers can choose to add and should not be removed.

comment:19 in reply to:  17 Changed 10 days ago by Klumbumbus

Replying to stoecker:

Replying to Klumbumbus:

In 17147/josm:

You think it is a good idea to encourage people to enter data which obviously is incompatible to the rest of the world?

The validity of these validator rules is clearly controversial. I don't see much benefit from these rules either. Also the wiki lists such tagging combination examples on different pages as valid. Avoiding false positives is much more important here, so I removed the rules for now.
Once a consensus was found in external discussions we can add rules based on that.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.