Modify

Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#19794 closed defect (fixed)

Tools: Add node: enter does not work

Reported by: Olga | Yanosik Owned by: team
Priority: normal Milestone: 20.09
Component: Core Version: latest
Keywords: template_report regression Cc: olgab@…, simon04

Description

Hello, after the last update it is not possible to press enter inside the coordinate window (shift+D) Instead, I have to press the OK key. It is much longer. Previously, it was possible to paste coordinates and press enter, now it does not work.
Please take a look at this error.
Thank you, greetings.
Olga | Yanosik

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Build-Date:2020-09-07 01:30:48
Revision:17013
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17013 pl) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1909 (18363)
Memory Usage: 869 MB / 989 MB (165 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (35248)
+ ImproveWay (29)
+ OpeningHoursEditor (35414)
+ PicLayer (35405)
+ Tracer2 (35499)
+ apache-commons (35524)
+ buildings_tools (35500)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ log4j (35092)
+ opendata (35513)
+ reverter (35499)
+ rex (53)
+ terracer (35499)
+ turnrestrictions (35515)
+ utilsplugin2 (35487)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1

Attachments (1)

19794.patch (1.4 KB) - added by GerdP 5 months ago.
this patch fixes this, not sure if this is the right way to do it

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 months ago by Klumbumbus

Cc: simon04 added
Keywords: regression added

regression somewhere here, likely r16971

comment:2 Changed 6 months ago by skyper

Ticket #19801 has been marked as a duplicate of this ticket.

comment:3 Changed 6 months ago by skyper

Summary: Tools-Add nodeTools: Add node: enter does not work

Changed 5 months ago by GerdP

Attachment: 19794.patch added

this patch fixes this, not sure if this is the right way to do it

comment:4 Changed 5 months ago by GerdP

Milestone: 20.09
Summary: Tools: Add node: enter does not work[Patch]Tools: Add node: enter does not work

comment:5 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 17078/josm:

fix #19794 - LatLonDialog: restore default action on Enter key stroke (regression from r16971)

comment:6 Changed 5 months ago by Don-vip

Summary: [Patch]Tools: Add node: enter does not workTools: Add node: enter does not work

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.