Modify

Opened 5 days ago

Closed 5 days ago

#19801 closed defect (duplicate)

Add node dialog, pressing enter key no longer works

Reported by: GOwin Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Activate Add node
  2. Input coordinates
  3. pressing Enter key will not execute action

What is the expected result?

Enter key will execute the action, adding node at given coordinates. This works as expected in previous versions.

What happens instead?

Nothing happens until the Ok button is pressed.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Revision:17013
Build-Date:2020-09-07 01:30:48
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17013 en) Linux Pop!_OS 20.04 LTS
Memory Usage: 3144 MB / 3144 MB (707 MB allocated, but free)
Java version: 11.0.8+10-post-Ubuntu-0ubuntu120.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: XFCE
Java package: openjdk-11-jre:amd64-11.0.8+10-0ubuntu1~20.04
fonts-noto: fonts-noto:all-20200323-1build1~ubuntu20.04.1
Program arguments: [${HOME}/Documents/default.joz, ${HOME}/Documents/Projects/OpenStreetMap/engagements/IM-TWG NDRRMC/data/PSA/psa_2015_schools.geojson]
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1595741614)
+ FastDraw (35499)
+ FixAddresses (35343)
+ Mapillary (1.5.25)
+ OpeningHoursEditor (35414)
+ RoadSigns (35510)
+ apache-commons (35524)
+ apache-http (35092)
+ buildings_tools (35500)
+ centernode (v1.0.3)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geotools (35169)
+ imagery_offset_db (35405)
+ intersection (0.0.7)
+ javafx-unixoid (35458)
+ jaxb (35092)
+ jna (35092)
+ josm-batch-downloader (1.0.2)
+ jts (35122)
+ log4j (35092)
+ measurement (35405)
+ merge-overlap (35248)
+ namemanager (35248)
+ reltoolbox (35529)
+ reverter (35499)
+ shrinkwrap (v1.0.2)
+ tageditor (35258)
+ terracer (35499)
+ todo (30306)
+ turnlanes-tagging (283)
+ turnrestrictions (35515)
+ undelete (35521)
+ utilsplugin2 (35487)
+ waydownloader (35405)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/PhilippinesAddresses&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- ${HOME}/Documents/Projects/#Kaart/JOSM/Kaart Styles 3.1.1.mapcss
- ${HOME}/Documents/Projects/#Kaart/JOSM/geometry_adjusted_paint.mapcss.css
- ${HOME}/Documents/Projects/#Kaart/JOSM/Reviewed_Features/reviewed_features.mapcss
- https://raw.githubusercontent.com/govvin/JOSM-styles/master/age.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
- ${HOME}/Documents/Projects/#Kaart/resources/data_age.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Overlapping%20Ways.mapcss
- https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart_QC.mapcss
- https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart-Styles.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/OsmoseValidations&zip=1

Last errors/warnings:
- 21753.345 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 21753.345 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 21753.347 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 21753.347 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 21753.369 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 24820.054 W: Unknown remote control parameter max_zoom, skipping it
- 24820.054 W: Unknown remote control parameter title, skipping it
- 74015.383 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 75063.923 W: Could not load Mapillary brand image!
- 75088.710 W: Could not load Mapillary brand image!

Attachments (0)

Change History (1)

comment:1 Changed 5 days ago by skyper

Resolution: duplicate
Status: newclosed
Version: latesttested

Closed as duplicate of #19794.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.