Modify

Opened 11 days ago

Closed 7 days ago

Last modified 7 days ago

#19596 closed defect (duplicate)

memory problem not saved

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-30 19:13:42 +0200 (Tue, 30 Jun 2020)
Build-Date:2020-07-01 01:30:51
Revision:16731
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16731 en) Windows 8 64-Bit
OS Build number: Windows 8 Pro (9200)
Memory Usage: 101 MB / 247 MB (30 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Last errors/warnings:
- W: java.nio.file.FileSystemException: C:\Users\<user.name>~1.DES\AppData\Local\Temp\josm_exec_powershell_1453230401358710917.txt: The process cannot access the file because it is being used by another process.
- W: Unable to request certificate of https://grca.nat.gov.tw
- E: Handled by bug report queue: javax.json.JsonException: Cannot auto-detect encoding, not enough chars


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (44) of main
javax.json.JsonException: Cannot auto-detect encoding, not enough chars
	at org.glassfish.json.UnicodeDetectingInputStream.detectEncoding(UnicodeDetectingInputStream.java:130)
	at org.glassfish.json.UnicodeDetectingInputStream.<init>(UnicodeDetectingInputStream.java:75)
	at org.glassfish.json.JsonParserImpl.<init>(JsonParserImpl.java:95)
	at org.glassfish.json.JsonProviderImpl.createParser(JsonProviderImpl.java:88)
	at javax.json.Json.createParser(Json.java:109)
	at org.openstreetmap.josm.io.GeoJSONReader.doParseDataSet(GeoJSONReader.java:355)
	at org.openstreetmap.josm.io.GeoJSONReader.parseDataSet(GeoJSONReader.java:375)
	at org.openstreetmap.josm.gui.io.importexport.GeoJSONImporter.importData(GeoJSONImporter.java:51)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:98)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:370)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:320)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 7 days ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18824.

comment:2 Changed 7 days ago by simon04

Type: enhancementdefect

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.