Modify

Opened 3 months ago

Closed 3 months ago

#18824 closed defect (invalid)

Error when opening a GeoJSON file

Reported by: orhygine Owned by: team
Priority: normal Milestone:
Component: Core geojson Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download GeoJSON from https://data.toulouse-metropole.fr/explore/dataset/filaire-de-voirie/export/?location=10,43.64168,1.42689&basemap=jawg.streets
  2. Open That GeoJSON into JOSM

What is the expected result?

GeoJSON should be opened into JOSM.

What happens instead?

An error occurs and file can't be loaded into JSOM.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-03-01 01:02:24 +0100 (Sun, 01 Mar 2020)
Revision:15969
Build-Date:2020-03-01 02:30:56
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15969 fr) Linux Ubuntu 19.10
Memory Usage: 383 MB / 2048 MB (152 MB allocated, but free)
Java version: 11.0.6+10-post-Ubuntu-1ubuntu119.10.1, Ubuntu, OpenJDK 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Java ATK Wrapper package: libatk-wrapper-java:all-0.35.0-3
fonts-noto: fonts-noto:-

Plugins:
+ ImproveWay (29)
+ Mapillary (1.5.20)
+ OpeningHoursEditor (35250)
+ PolygonCutOut (v0.7)
+ apache-commons (35092)
+ apache-http (35092)
+ buildings_tools (35248)
+ cadastre-fr (35332)
+ changeset-viewer (22)
+ continuosDownload (91)
+ ejml (35122)
+ geochat (35248)
+ geotools (35169)
+ gridify (1577091848)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ measurement (35248)
+ opendata (35330)
+ reverter (35313)
+ todo (30306)
+ utilsplugin2 (35334)
+ wikipedia (1.1.3)

Map paint styles:
+ ${HOME}/osm/work.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- E: Handled by bug report queue: javax.json.JsonException: Cannot auto-detect encoding, not enough chars


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (59) of main
javax.json.JsonException: Cannot auto-detect encoding, not enough chars
	at org.glassfish.json.UnicodeDetectingInputStream.detectEncoding(UnicodeDetectingInputStream.java:130)
	at org.glassfish.json.UnicodeDetectingInputStream.<init>(UnicodeDetectingInputStream.java:75)
	at org.glassfish.json.JsonParserImpl.<init>(JsonParserImpl.java:95)
	at org.glassfish.json.JsonProviderImpl.createParser(JsonProviderImpl.java:88)
	at javax.json.Json.createParser(Json.java:109)
	at org.openstreetmap.josm.io.GeoJSONReader.doParseDataSet(GeoJSONReader.java:350)
	at org.openstreetmap.josm.io.GeoJSONReader.parseDataSet(GeoJSONReader.java:370)
	at org.openstreetmap.josm.gui.io.importexport.GeoJSONImporter.importData(GeoJSONImporter.java:51)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:95)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:369)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:319)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)

Attachments (0)

Change History (2)

comment:1 Changed 3 months ago by simon04

Component: CoreCore geojson

I cannot reproduce. This is the message digest of the file I downloaded from the URL:

$ sha1sum filaire-de-voirie.geojson 
d7fb651d4858246bf012562c5bb0a2e8c7fdefc2  filaire-de-voirie.geojson

comment:2 Changed 3 months ago by orhygine

Resolution: invalid
Status: newclosed

There is actually an issue with the source web site. The downloaded file is not consistent between 2 downloads. After several tries, I succeded in opening the file in JOSM. No issue at all with JOSM. Thanks for the fast answear !

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.