Modify

Opened 4 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#19493 closed defect (fixed)

Switching to/from wireframe mode much slower than previous versions

Reported by: skquinn Owned by: GerdP
Priority: normal Milestone: 20.09
Component: Core Version: tested
Keywords: template_report performance regression Cc: taylor.smock

Description

What steps will reproduce the problem?

  1. Control-W to toggle wireframe mode

What is the expected result?

The change occurs within 0.5 seconds, worst case (usually faster).

What happens instead?

4-5 seconds go by, during which time input is blocked, before JOSM switches to or from wireframe mode.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-30 19:13:42 +0200 (Tue, 30 Jun 2020)
Revision:16731
Build-Date:2020-07-01 01:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16731 en) Linux Ubuntu 18.04.4 LTS
Memory Usage: 1063 MB / 3959 MB (361 MB allocated, but free)
Java version: 11.0.7+10-post-Ubuntu-2ubuntu218.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1360x768 (scaling 1.0x1.0)
Maximum Screen Size: 1360x768
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: openjdk-11-jre:amd64-11.0.7+10-2ubuntu2~18.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
libcommons-compress-java: libcommons-compress-java:all-1.18-1~18.04
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (35405)
+ CADTools (1008)
+ CommandLine (35405)
+ EasyPresets (1583691763)
+ FastDraw (35499)
+ FixAddresses (35343)
+ HouseNumberTaggingTool (35248)
+ OpeningHoursEditor (35414)
+ TombPlugin (58)
+ alignways (35474)
+ apache-commons (35362)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35500)
+ changeset-viewer (22)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ damn (0.1.2)
+ editgpx (35248)
+ ejml (35313)
+ fieldpapers (v0.5.0)
+ graphview (35405)
+ imagery_offset_db (35405)
+ jna (35092)
+ josm-batch-downloader (1.0.2)
+ livegps (35248)
+ log4j (35092)
+ measurement (35405)
+ merge-overlap (35248)
+ michigan_left (35248)
+ pbf (35446)
+ poly (35248)
+ print (35248)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ reverter (35499)
+ rex (53)
+ splinex (35454)
+ tageditor (35258)
+ terracer (35499)
+ turnlanes-tagging (283)
+ turnrestrictions (35405)
+ undelete (35499)
+ utilsplugin2 (35487)
+ waypoint_search (35248)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/AdvertisingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/US.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Community_Centre&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/TurnLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Animal_facilities&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Baby_friendliness&zip=1
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/WifiHotspots&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Schools&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NoFeature&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/SuspiciousSwimming_Pool&zip=1
- https://josm.openstreetmap.de/josmfile?page=Rules/KeepRight&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/MissingWeekdays&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/QAToolInspiredValidations&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/OSMLint&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/Pictures&zip=1

Last errors/warnings:
- W: javax.imageio.IIOException: Caught exception during read:. Cause: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
- E: Failed to locate image 'traffic_signs_presets/tunnel.png'
- W:  Tunnel: Could not get presets icon traffic_signs_presets/tunnel.png
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- W: javax.net.ssl.SSLException: Socket closed. Cause: javax.net.ssl.SSLException: Socket closed. Cause: java.net.SocketException: Socket closed
- E: javax.net.ssl.SSLException: Socket closed. Cause: javax.net.ssl.SSLException: Socket closed. Cause: java.net.SocketException: Socket closed

Attachments (0)

Change History (12)

comment:1 Changed 4 months ago by Klumbumbus

Keywords: performance regression added

comment:2 Changed 4 months ago by Klumbumbus

Ticket #19497 has been marked as a duplicate of this ticket.

comment:3 Changed 3 months ago by skyper

Ticket #19507 has been marked as a duplicate of this ticket.

comment:4 Changed 3 months ago by simon04

Milestone: 20.07

comment:5 Changed 3 months ago by skyper

Is this in fact a problem of rendering data in general? I have the feeling that also rendering default style plus some extras needs more time now than two month ago, but need to test/time it.

comment:6 Changed 3 months ago by simon04

Milestone: 20.0720.08

comment:7 Changed 7 weeks ago by simon04

Milestone: 20.0820.09

comment:9 Changed 3 weeks ago by GerdP

Owner: changed from team to GerdP
Status: newassigned

I don't see a big difference with the defaut map style only, but with additional map styles.
With r16569 the styles are loaded each time you switch, this takes long no matter how many objects are displayed.
2020-10-02 08:02:28.496 FINE: Initializing map style resource://styles/standard/elemstyles.mapcss completed in 46 ms
2020-10-02 08:02:28.548 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1 completed in 39 ms
2020-10-02 08:02:28.722 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1 completed in 173 ms
2020-10-02 08:02:28.724 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1 completed in 1 ms
2020-10-02 08:02:28.727 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1 completed in 3 ms
2020-10-02 08:02:28.728 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1 completed in 1 ms
2020-10-02 08:02:30.516 FINE: Initializing map style https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip completed in 1.8 s
2020-10-02 08:02:33.825 FINE: Initializing map style resource://styles/standard/elemstyles.mapcss completed in 31 ms
2020-10-02 08:02:33.860 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1 completed in 29 ms
2020-10-02 08:02:33.917 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1 completed in 57 ms
2020-10-02 08:02:33.918 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1 completed in 1 ms
2020-10-02 08:02:33.922 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1 completed in 2 ms
2020-10-02 08:02:33.923 FINE: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1 completed in 1 ms
2020-10-02 08:02:35.918 FINE: Initializing map style https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip completed in 2.0 s

comment:10 Changed 3 weeks ago by GerdP

Cc: taylor.smock added

regression from #19196

comment:11 Changed 3 weeks ago by GerdP

Resolution: fixed
Status: assignedclosed

In 17083/josm:

fix #19493: Switching to/from wireframe mode much slower than previous versions
Add mappaint.renderer-class-name to ignore list so that map paint styles are not reloaded each time when the renderer is changed

comment:12 Changed 3 weeks ago by GerdP

There seems to be a special issue with https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip
This takes much longer than the other styles.
That's because it is very complex, found no special problem in it.

Last edited 3 weeks ago by GerdP (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.