Modify

Opened 2 years ago

Closed 5 days ago

#19435 closed defect (duplicate)

Authentication failed dialog window remains hidden under the OAuth window

Reported by: jBeata Owned by: jBeata
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report oauth semi-automatic focus Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Open JOSM
  2. Logg-out from JOSM
  3. Download OSM data and MapWithAI layer from your area of choice
  4. Add any missing element to OSM
  5. Select Upload Data Button
  6. Complete data upload related details - comment, source
  7. Select Upload Changes button
  8. Select OAuth -> Semi-automatic authorisation procedure
  9. Select Retrieve Request Token

What is the expected result?

The https://www.openstreetmap.org/oauth/authorize? with the corresponding oauth_token is opened.

What happens instead?

The https://www.openstreetmap.org/oauth/authorize? page is not opened, even if the Retrieve Access Token is selected several times. The "Creating changeset" dialog window changes focus for a short period of time with the OAuth window.
If you close the OAuth window the "Authentification failed" message pops-up.

Please provide any additional information below. Attach a screenshot if possible.

Upload1

Upload2

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-21 21:06:50 +0200 (Sun, 21 Jun 2020)
Build-Date:2020-06-22 01:30:49
Revision:16703
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16703 en_GB) Mac OS X 10.15.5
OS Build number: Mac OS X 10.15.5 (19F101)
Memory Usage: 1632 MB / 3641 MB (1057 MB allocated, but free)
Java version: 1.8.0_232-b09, AdoptOpenJDK, OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 188942015 1920x1080 (scaling 1.0x1.0), Display 69734662 1792x1120 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1120
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [-ea, -Dfile.encoding=UTF-8]
Program arguments: [--debug]
Dataset consistency test: No problems found

Plugins:
+ mapwithai-dev (unknown)
+ utilsplugin2 (35487)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.MissingOAuthAccessTokenException
- E: Authentication failed - <html>Failed to authenticate at the OSM server 'https://api.openstreetmap.org/api'.<br>You are using OAuth to authenticate but currently there is no<br>OAuth Access Token configured.<br>Please open the Preferences dialogue and generate or enter an Access Token.</html>

Attachments (2)

Screenshot 2020-06-25 at 17.58.01.png (279.0 KB) - added by jBeata 2 years ago.
Upload1
Screenshot 2020-06-25 at 18.08.23.png (259.5 KB) - added by jBeata 2 years ago.
Upload2

Download all attachments as: .zip

Change History (13)

Changed 2 years ago by jBeata

Upload1

Changed 2 years ago by jBeata

Upload2

comment:1 Changed 2 years ago by jBeata

Description: modified (diff)

comment:2 Changed 2 years ago by skyper

What is your login status on the OSM-Website, see #14091. I seldomly use semi-auto, these days.

comment:3 Changed 2 years ago by skyper

Description: modified (diff)
Keywords: oauth semi-automatic added
Version: latest

comment:4 Changed 2 years ago by skyper

Description: modified (diff)

comment:5 Changed 2 years ago by skyper

Description: modified (diff)

comment:6 Changed 2 years ago by skyper

Owner: changed from team to jBeata
Status: newneedinfo

comment:7 Changed 23 months ago by jBeata

This issue is still reproducing also with just only a single OSM Data layer present.

comment:8 in reply to:  7 Changed 23 months ago by skyper

Replying to jBeata:

This issue is still reproducing also with just only a single OSM Data layer present.

Might you, please, have a look at the ticket mentioned below and answer the question. Thanks.

Replying to skyper:

What is your login status on the OSM-Website, see #14091. I seldomly use semi-auto, these days.

comment:9 Changed 7 months ago by gaben

Keywords: focus added

I think it is duplicate of #16485.

comment:10 in reply to:  9 Changed 7 months ago by skyper

Replying to gaben:

I think it is duplicate of #16485.

That is the ultimate bug, but why does semi-automatic OAuth fail in first place?
I have to test, if #14091 is still a reproducible.

comment:11 Changed 5 days ago by gaben

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #16485.
As @skyper mentioned, for the failing OAuth see #14091.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.