Modify

Opened 3 weeks ago

Closed 3 weeks ago

#19422 closed defect (fixed)

TMS image source accessed with incorrect min & max arguments

Reported by: dido Owned by: simon04
Priority: normal Milestone: 20.06
Component: Core Version:
Keywords: template_report regression Cc:

Description (last modified by dido)

What steps will reproduce the problem?

  1. Click the download icon
  2. Exception happens (TMS image source selected for the download window)
  3. Same image source can be displayed normally through imagery menu
  4. Problem ocurred after JOSM updated from an April 2019 version to the current one (June 2020)

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-02 08:27:29 +0200 (Tue, 02 Jun 2020)
Build-Date:2020-06-02 11:11:35
Revision:16538
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16538 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 247 MB / 989 MB (164 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Plugins:
+ CommandLine (35405)
+ SeaMapEditor (35480)
+ apache-commons (35362)
+ changeset-viewer (22)
+ continuosDownload (91)
+ ejml (35313)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ measurement (35405)
+ opendata (35405)
+ turnrestrictions (35405)
+ utilsplugin2 (35476)

Tagging presets:
+ (...)\bgmpresets.xml

Map paint styles:
+ (...)\BGMountains.mapcss

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 740) cannot be greater than max (1 595 236 682 740)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 740) cannot be greater than max (1 595 236 682 740)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 740) cannot be greater than max (1 595 236 682 740)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 730) cannot be greater than max (1 595 236 682 730)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 740) cannot be greater than max (1 595 236 682 740)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 740) cannot be greater than max (1 595 236 682 740)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 750) cannot be greater than max (1 595 236 682 750)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 750) cannot be greater than max (1 595 236 682 750)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 682 750) cannot be greater than max (1 595 236 682 750)
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter min (1 608 196 849 652) cannot be greater than max (1 595 236 849 652)

OSM API: (...)/api


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: TMS-downloader-15 (72)
java.lang.IllegalArgumentException: Parameter min (1 608 196 849 652) cannot be greater than max (1 595 236 849 652)
	at org.openstreetmap.josm.tools.Utils.clamp(Utils.java:1542)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.parseHeaders(TMSCachedTileLoaderJob.java:263)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.loadObject(JCSCachedTileLoaderJob.java:337)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:225)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (8)

comment:1 Changed 3 weeks ago by dido

Description: modified (diff)

comment:2 Changed 3 weeks ago by Klumbumbus

Which imagery source did you choose?

comment:3 Changed 3 weeks ago by dido

tms:http://bgmtile.uni-plovdiv.net:40158/{z}/{x}/{y}.png

Same behavior can be observed with any tms source,though - tested also with OpenStreetMap (Standard Black & White).

comment:4 in reply to:  3 Changed 3 weeks ago by skyper

Replying to dido:

tms:http://bgmtile.uni-plovdiv.net:40158/{z}/{x}/{y}.png

Same behavior can be observed with any tms source,though - tested also with OpenStreetMap (Standard Black & White).

According to documentation on Maps#TileMapServicesTMS {z} should be {zoom}. Though, I am not sure if this helps.

comment:5 Changed 3 weeks ago by stoecker

Looks like an overflow because of a large zoom level. What's the zoom level you used?

comment:6 Changed 3 weeks ago by dido

I cannot see the zoom level in the download window itself, but I expect it's as usual - sth like 14-16.

A hint here - if I browse the same image layer in the main window, the download window would then reuse available tiles from the cache and does not throw an exception. Exception would occur if I drag a bit around in the download window where no cached tiles exist.

comment:7 in reply to:  5 Changed 3 weeks ago by simon04

Keywords: regression added
Milestone: 20.06
Owner: changed from team to simon04
Status: newassigned

Regression of r16431.

comment:8 Changed 3 weeks ago by simon04

Resolution: fixed
Status: assignedclosed

In 16692/josm:

fix #19422 - IAE in TMSCachedTileLoaderJob.parseHeaders

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.