Modify

Opened 3 months ago

Closed 4 weeks ago

Last modified 3 weeks ago

#19293 closed defect (fixed)

Double encoded spaces when viewing wikipedia article link

Reported by: Claudius Owned by: team
Priority: normal Milestone: 20.07
Component: Core tag2link Version:
Keywords: template_report, macosx, url encoding Cc:

Description

What steps will reproduce the problem?

  1. Load object https://www.openstreetmap.org/way/168347114
  2. In the tag list of the object right-click on the wikipedia tag entry (which should show the value "de:Wohnhausgruppe Herderstraße") and select "View Wikipedia article"

What is the expected result?

Wikipedia URL https://de.wikipedia.org/wiki/Wohnhausgruppe%20Herderstra%C3%9Fe to be opened

What happens instead?

Invalid wikipedia URL https://de.wikipedia.org/wiki/Wohnhausgruppe%2520Herderstra%C3%9Fe is opened, because the percent character of the %20 space encoding is encoded once more

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-05-24 22:20:58 +0200 (Sun, 24 May 2020)
Build-Date:2020-05-25 01:30:47
Revision:16498
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16498 fa) Mac OS X 10.15.4
OS Build number: Mac OS X 10.15.4 (19E287)
Memory Usage: 854 MB / 1820 MB (614 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69734208 1440x900
Maximum Screen Size: 1440x900
VM arguments: [-Djava.security.policy=file:<java.home>/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=${HOME}/Downloads/josm-latest.jnlp, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Dmacosx.jnlpx.dock.name=JOSM (development version), -Dmacosx.jnlpx.dock.icon=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/25/4c122699-7b178335.icns, -Djnlpx.jvm="<java.home>/bin/java"]
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (1537115529)
+ Mapillary (1.5.23)
+ OpeningHoursEditor (35414)
+ apache-commons (35362)
+ apache-http (35092)
+ buildings_tools (35405)
+ indoorhelper (35405)
+ javafx-osx (35375)
+ jna (35092)
+ pt_assistant (2.1.10-79-gb14a159)
+ reverter (35409)
+ tageditor (35258)
+ turnlanes (35405)
+ turnlanes-tagging (283)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/TurnLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OpenPisteMap&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Power_Mapping_Utility_Simple&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Healthcare&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
+ https://github.com/osmlab/appledata/archive/josm_paint_inline_validation.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1
+ <josm.userdata>/styles/sit.mapcss
- <josm.userdata>/styles/sit.mapcss

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/OSMLint&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/KeepRight&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/QAToolInspiredValidations&zip=1

Attachments (0)

Change History (8)

comment:1 Changed 3 months ago by Klumbumbus

It works fine for me. Console:

2020-05-25 15:25:31.557 INFORMATION: Öffne URL: https://de.wikipedia.org/wiki/Wohnhausgruppe%20Herderstraße

comment:2 Changed 3 months ago by Claudius

Doesn't reproduce on Windows 10, but on Mac OS X using Safari, Chrome or Firefox as the system's default browser

comment:3 Changed 3 months ago by skyper

Seems to be a MacOS X problem. Can not reproduce on Linux:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-05-24 22:20:58 +0200 (Sun, 24 May 2020)
Revision:16498
Build-Date:2020-05-25 01:30:47
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16498 en) Linux Debian GNU/Linux 10 (buster)
Java version: 11.0.7+10-post-Debian-3deb10u1, Debian, OpenJDK 64-Bit Server VM

comment:4 Changed 3 months ago by simon04

Component: CoreCore tag2link
Keywords: macosx url encoding added

comment:5 Changed 4 weeks ago by Stereo

I can indeed reproduce this on a current JOSM on macOS, Java 14.

comment:6 Changed 4 weeks ago by simon04

Resolution: fixed
Status: newclosed

In 16774/josm:

fix #19293 - Tag2link/wikipedia: replace space with underscore

comment:7 Changed 4 weeks ago by simon04

Milestone: 20.07

comment:8 Changed 3 weeks ago by simon04

Ticket #19447 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.