Modify

Opened 21 months ago

Closed 14 months ago

Last modified 12 months ago

#19771 closed defect (fixed)

Bad link from wikimedia_commons

Reported by: pyrog Owned by: simon04
Priority: normal Milestone: 21.04
Component: Core tag2link Version:
Keywords: template_report macosx Cc:

Description

What steps will reproduce the problem?

  1. Open https://www.openstreetmap.org/way/81958418
  2. Right click on wikimedia_commons tag
  3. Select see image on Wikimedia Commons

What is the expected result?

Show image webpage.

What happens instead?

Display Bad title. The requested page title contains invalid characters: "%20".

Space characters à replaced by %2520 instead of _ or %20

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Build-Date:2020-09-07 01:30:48
Revision:17013
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17013 fr) Mac OS X 10.14.6
OS Build number: Mac OS X 10.14.6 (18G4032)
Memory Usage: 743 MB / 1820 MB (209 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69732928 1280x800 (scaling 1.0x1.0)
Maximum Screen Size: 1280x800
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DApplicationDirectory=${HOME}/Applications, -DAutosavedInformationDirectory=${HOME}/Library/Autosave Information, -DDesktopDirectory=${HOME}/Desktop, -DDownloadsDirectory=${HOME}/Downloads, -DMoviesDirectory=${HOME}/Movies, -DMusicDirectory=${HOME}/Music, -DPicturesDirectory=${HOME}/Pictures, -DSharedPublicDirectory=${HOME}/Public, -DSystemLibraryDirectory=/Library, -DSystemApplicationSupportDirectory=/Library/Application Support, -DSystemCachesDirectory=/Library/Caches, -DSystemApplicationDirectory=/Applications, -DSystemUserDirectory=/Users, -DUserHome=${HOME}, -DSandboxEnabled=true, -DLaunchModifierFlags=0, -DLaunchModifierFlagCapsLock=false, -DLaunchModifierFlagShift=false, -DLaunchModifierFlagControl=false, -DLaunchModifierFlagOption=false, -DLaunchModifierFlagCommand=false, -DLaunchModifierFlagNumericPad=false, -DLaunchModifierFlagHelp=false, -DLaunchModifierFlagFunction=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
+ PicLayer (35405)
+ SeaMapEditor (35480)
+ apache-commons (35524)
+ apache-http (35092)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ buildings_tools (35500)
+ cadastre-fr (35539)
+ conflation (0.6.6)
+ ejml (35313)
+ geotools (35169)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ log4j (35092)
+ measurement (35405)
+ opendata (35513)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ reverter (35499)
+ utilsplugin2 (35487)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Telecom&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Healthcare&zip=1
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedWalkingNodeNetworks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1

Validator rules:
+ https://github.com/Jungle-Bus/transport_mapcss/raw/gh-pages/transport.validator.zip
+ ${HOME}/Downloads/Rules_Pictures.validator.mapcss

Last errors/warnings:
- 13080,720 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out
- 13179,205 W: java.net.SocketTimeoutException: Read timed out
- 13188,105 W: java.net.SocketTimeoutException: Read timed out
- 13785,160 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out
- 13785,160 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out
- 13785,160 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out
- 13785,162 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out
- 13785,163 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out
- 13785,168 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out
- 14842,131 W: java.net.SocketTimeoutException: Read timed out. Cause : java.net.SocketTimeoutException: Read timed out

Attachments (0)

Change History (15)

comment:1 Changed 21 months ago by stoecker

See #19293 for a previous version of this issue.

comment:2 Changed 20 months ago by Don-vip

Component: CoreCore tag2link

comment:3 Changed 20 months ago by Don-vip

Owner: changed from team to pyrog
Status: newneedinfo

Works for me with r17164, can you please try with latest?

comment:5 Changed 20 months ago by simon04

I cannot reproduce

Revision:17159
Is-Local-Build:true
Build-Date:2020-10-11 11:18:07

Identification: JOSM/1.5 (17159 SVN en_GB) Linux Arch Linux
Memory Usage: 200 MB / 7872 MB (43 MB allocated, but free)
Java version: 16-ea+19-985, Oracle Corporation, OpenJDK 64-Bit Server VM
Look and Feel: com.formdev.flatlaf.FlatLightLaf
Screen: :0.0 3840x2160 (scaling 1.0x1.0)
Maximum Screen Size: 3840x2160
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: i3

2020-10-11 18:52:11.511 INFO: Opening URL: https://commons.wikimedia.org/wiki/File:Côte%20de%20granite%20rose%20-%20Trégastel%20à%20Ploumanac'h%20-%2020190723%20-%20025.jpg

comment:6 Changed 20 months ago by pyrog

Is it an issue with the macOS package ?

comment:7 Changed 20 months ago by Don-vip

Keywords: macosx added

I'll test on macOS.

comment:8 Changed 16 months ago by pyrog

Bug already there with macOS package JOSM version 17428, Java 15.0.0.1

Same issue with josm-tested.jar version 17428, Java 1.8.0_271

wikimedia_commons=File:Blois-sur-Seille, le téléphérique.jpg

give https://commons.wikimedia.org/wiki/File:Blois-sur-Seille,%2520le%2520téléphérique.jpg
instead of https://commons.wikimedia.org/wiki/File:Blois-sur-Seille,_le_téléphérique.jpg

comment:9 Changed 16 months ago by pyrog

Strangely, the link work fine for the key wikimedia_commons=File:Blois-sur-Seille, statue Jeanne dArc.jpg

https://commons.wikimedia.org/wiki/File:Blois-sur-Seille,_statue_Jeanne_dArc.jpg

The difference with the last example seem that it is a unicode string, and this one not.

comment:11 Changed 14 months ago by pyrog

Hi,

This issue is still there with the latest JOSM version 17560 (packaged and josm-tested.jar).

The behaviour is a bit different:
When selecting "View image on Wikimedia Commons" with a right click, nothing happened.

Examples (with links to OSM website):

wikimedia_commons=File:Blois-sur-Seille, le téléphérique.jpg (France)
wikimedia_commons=File:Stolperstein Eckenheimer Landstraße 71, Rosa Ebe, Nordend West, Frankfurt am Main.jpg (Germany)
wikimedia_commons=File:PL-Fénis-01.jpg (Italy)
wikimedia_commons=File:Castillopeña.JPG (spain)
wikimedia_commons=File:Museo del Antiguo Legado Estadounidense, Tánger, Marruecos, 2015-12-11, DD 44-46 HDR.JPG (Marocco)
wikimedia_commons=File:குழித்துறை_தொடருந்து_நிலையம்.jpg (India)
wikimedia_commons=File:連理の枝.jpg (Japan)
wikimedia_commons=File:东百中心A馆10楼瞭望台西三坊七巷.jpg (China)
wikimedia_commons=File:Темерчинское урочище - землянка IMG 1560.jpg (Russia)
wikimedia_commons=File:Vadested Tjøme.jpg (Norway)
wikimedia_commons=File:Trilhos ferroviários em Uruguaiana, perto do Ponte Internacional • 5.jpg (Brasil)

Tested on macOS Big Sur.

Last edited 14 months ago by pyrog (previous) (diff)

comment:12 Changed 14 months ago by simon04

Milestone: 21.04
Owner: changed from pyrog to simon04
Status: needinfoassigned

comment:13 Changed 14 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 17736/josm:

fix #19771 - Tag2Link: use percent encoding for Wikimedia Commons URLs

comment:14 Changed 13 months ago by pyrog

Thank you very much 😀

comment:15 Changed 12 months ago by simon04

In 17909/josm:

see #19771 - Tag2Link: use URL encoding for Wikimedia Commons URLs

Removes com.google.gdata.util.common.base.PercentEscaper dependency (provided via signpost-core)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.