Modify

Opened 8 weeks ago

Closed 8 weeks ago

#19262 closed defect (duplicate)

an error message appears when trying to open a file. I use Ubuntu 20.04 (daily update). Best regards Oliver H.

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Revision:16239
Build-Date:2020-04-06 00:18:43
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16239 en) Linux Ubuntu 20.04 LTS
Memory Usage: 215 MB / 1968 MB (111 MB allocated, but free)
Java version: 11.0.7+10-post-Ubuntu-2ubuntu218.04, Ubuntu, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x1080
Maximum Screen Size: 3840x1080
VM arguments: [-Duser.home=${HOME}]

Last errors/warnings:
- E: Handled by bug report queue: java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/<user.name>/��ffentlich
- E: Handled by bug report queue: java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/<user.name>/��ffentlich


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: Basic L&F File Loading Thread (62)
java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/confidencebanana/��ffentlich
	at java.base/sun.nio.fs.UnixPath.encode(UnixPath.java:145)
	at java.base/sun.nio.fs.UnixPath.<init>(UnixPath.java:69)
	at java.base/sun.nio.fs.UnixFileSystem.getPath(UnixFileSystem.java:279)
	at java.base/java.nio.file.Path.of(Path.java:147)
	at java.base/java.nio.file.Paths.get(Paths.java:69)
	at java.desktop/sun.awt.shell.ShellFolder.getShellFolder(ShellFolder.java:247)
	at java.desktop/javax.swing.filechooser.FileSystemView.getFiles(FileSystemView.java:523)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run0(BasicDirectoryModel.java:290)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run(BasicDirectoryModel.java:279)
	at java.base/java.lang.Thread.run(Thread.java:834)

Attachments (0)

Change History (1)

comment:1 Changed 8 weeks ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14596.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.