Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#19260 closed enhancement (fixed)

[Patch] Show menu on right-click in History of relation members

Reported by: GerdP Owned by: team
Priority: normal Milestone: 20.05
Component: Core Version:
Keywords: Cc: simon04, hjart

Description

Since #19254 a double click shows the history of the relation member. I think we should also show a popup on a right click offering the same actions as in the NodeListViewer.

Attachments (2)

19260.patch (5.2 KB) - added by GerdP 6 months ago.
19260.2.patch (11.7 KB) - added by GerdP 6 months ago.
move common code into class HistoryViewerPanel

Download all attachments as: .zip

Change History (11)

Changed 6 months ago by GerdP

Attachment: 19260.patch added

comment:1 Changed 6 months ago by GerdP

The patch implements the menu in RelationMemberListViewer similar to the NodeListViewer.
Unfortunately it also duplicates most of the code :(
Is it possible to have the common code in a new class?

comment:2 Changed 6 months ago by skyper

Summary: Show menu on right-click in History of relation members[Patch] Show menu on right-click in History of relation members

comment:3 Changed 6 months ago by simon04

+1 for adding the popup menu. You could simply add the NAME and SHORT_DESCRIPTION as constructor arguments.

Changed 6 months ago by GerdP

Attachment: 19260.2.patch added

move common code into class HistoryViewerPanel

comment:4 Changed 6 months ago by GerdP

I wonder what class RepaintOnFocusChange in TagInfoViewer does. I see no effect when I remove the line

    table.addFocusListener(new RepaintOnFocusChange());

and the code for this class. Introduced for #13050

comment:5 Changed 6 months ago by GerdP

Resolution: fixed
Status: newclosed

In 16473/josm:

fix #19260: Show menu on right-click in History of relation members
Common code for NodeListViewer and RelationMemberListViewer was moved to HistoryViewerPanel

comment:6 Changed 6 months ago by Klumbumbus

Milestone: 20.05

comment:7 Changed 6 months ago by simon04

Great! :-)

comment:8 Changed 6 months ago by simon04

Ticket #17208 has been marked as a duplicate of this ticket.

comment:9 Changed 6 months ago by simon04

Cc: hjart added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.