Modify

Opened 8 months ago

Closed 8 months ago

Last modified 7 months ago

#19066 closed defect (fixed)

Confusing message: amenity=recycling without ^recycling:

Reported by: GerdP Owned by: Klumbumbus
Priority: normal Milestone: 20.05
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. have a node tagged with amenity=recycling + recycling_type=container
  2. run validator

What is the expected result?

not sure

What happens instead?

message "amenity=recycling without ^recycling:" is produced. The "^recycling:" phrase is probably part of a regular expression?

Please provide any additional information below. Attach a screenshot if possible.

The rule is in combinations.mapcss, search for ^recycling.

Build-Date:2020-04-11 10:13:52
Revision:16252
Is-Local-Build:true

Identification: JOSM/1.5 (16252 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 703 MB / 1753 MB (298 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:51853, -ea, -Dfile.encoding=UTF-8]
Program arguments: [--debug]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35414)
+ PolygonCutOut (v0.7)
+ apache-commons (35362)
+ buildings_tools (35405)
+ continuosDownload (91)
+ ejml (35313)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ merge-overlap (35248)
+ o5m (35248)
+ opendata (35405)
+ pbf (35248)
+ poly (35248)
+ reverter (35409)
+ undelete (35405)
+ utilsplugin2 (35405)

Validator rules:
+ c:\josm\core\resources\data\validator\geometry.mapcss

Attachments (0)

Change History (16)

comment:1 Changed 8 months ago by GerdP

Description: modified (diff)

comment:2 Changed 8 months ago by GerdP

Description: modified (diff)

comment:3 Changed 8 months ago by GerdP

Description: modified (diff)
Summary: Confusing message: amenity=recycling without ^recyclingConfusing message: amenity=recycling without ^recycling:

comment:4 Changed 8 months ago by GerdP

I guess this message is meant to tell me that I should add one or more tags with prefix recycling: , e.g. recycling:glass?
I think it would better to say this without a regex.

comment:5 in reply to:  4 Changed 8 months ago by Klumbumbus

Milestone: 20.04

Replying to GerdP:

I guess this message is meant to tell me that I should add one or more tags with prefix recycling: , e.g. recycling:glass?

Yes.

comment:6 Changed 8 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 16254/josm:

fix #19066 - Improve recycling validator message

comment:7 Changed 8 months ago by Klumbumbus

I have chosen this tr("{0} without {1}", "{0.tag}", "recycling:*") format because

  • it doesn't add a translation string
  • it keeps the key in the placeholder which is required for #11153

comment:8 Changed 8 months ago by GerdP

Thanks. There are a few more messages with this pattern, e.g.

*[source:addr                  ][!/^addr:/],
*[source:maxspeed              ][!/^maxspeed:?/] {

relation[type=restriction][!/^restriction/], /* see #11586 */

Not sure how to find all of them.

comment:9 Changed 8 months ago by Klumbumbus

Resolution: fixed
Status: closedreopened

comment:10 Changed 8 months ago by Klumbumbus

Owner: changed from team to Klumbumbus
Status: reopenednew

comment:11 Changed 8 months ago by skyper

By the way, source:name with noname=yes should not create a warning.

comment:12 Changed 8 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 16255/josm:

fix #19066 - Improve some validator messages

comment:13 in reply to:  8 ; Changed 8 months ago by Klumbumbus

Replying to GerdP:

Not sure how to find all of them.

The search pattern is !/ or [!/, I found no further cases.
Rules with [/ work fine, but there seems to be another regression, which might be related to this ticket, but I create a new ticket.

Last edited 8 months ago by Klumbumbus (previous) (diff)

comment:14 in reply to:  13 Changed 8 months ago by Klumbumbus

Replying to Klumbumbus:

another regression, which might be related to this ticket, but I create a new ticket.

Seems not related. --> #19069

comment:15 Changed 8 months ago by Klumbumbus

In 16258/josm:

see #19066 - Move forgotten asserts

comment:16 Changed 7 months ago by Klumbumbus

Milestone: 20.0420.05

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.