Modify

Opened 13 months ago

Last modified 13 months ago

#19001 reopened defect

download object reports downloading incomplete data

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by skyper)

EDIT: The data handling is OK, but the message in the console is strange:

What steps will reproduce the problem?

  1. Download object way 426727372
  2. Get a way with four child nodes, see attached file
  3. Compare the number of children with history or advanced info
  4. Look at the console output, see below

What is the expected result?

Number should be the same
No additional info message

What happens instead?

Number is different: 4 vs 5. The downloaded way is missing one node.
An additional info message about incomplete data

Please provide any additional information below. Attach a screenshot if possible.

No use of overpass.

terminal log:

2020-03-29 15:28:08.465 INFO: GET https://api.openstreetmap.org/api/0.6/ways?ways=426727372 -> HTTP/1.1 200 (157 ms)
2020-03-29 15:28:08.474 INFO: Way 426727372 with 5 nodes is incomplete because at least one node was missing in the loaded data.
Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-03-27 15:39:19 +0100 (Fri, 27 Mar 2020)
Revision:16205
Build-Date:2020-03-28 02:30:56
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (2)

josm_bug_download_object_missing_node.png (54.6 KB) - added by skyper 13 months ago.
screenshot
josm_download_object_incomplete_way.osm (1.0 KB) - added by skyper 13 months ago.
incomplete data after download object

Download all attachments as: .zip

Change History (8)

Changed 13 months ago by skyper

screenshot

comment:1 Changed 13 months ago by skyper

Description: modified (diff)

Changed 13 months ago by skyper

incomplete data after download object

comment:2 Changed 13 months ago by GerdP

Resolution: invalid
Status: newclosed

The way is not incomplete. Question is how you count the duplicated node.

comment:3 Changed 13 months ago by Klumbumbus

Yes, the way is fine, but the message in the console is strange
2020-03-29 15:28:08.474 INFO: Way 426727372 with 5 nodes is incomplete because at least one node was missing in the loaded data.

comment:4 Changed 13 months ago by skyper

Priority: criticalnormal

Yeah, I got confused by the message in the console. The data is ok.

comment:5 Changed 13 months ago by GerdP

Yes, this message is rather useless. When you download a list of ways into an empty layer it will appear for each way, because we first download the ways and then the nodes using the multifetch api.

comment:6 Changed 13 months ago by skyper

Description: modified (diff)
Resolution: invalid
Status: closedreopened
Summary: download object downloads incomplete datadownload object reports downloading incomplete data

I changed the ticket to reflect the problem.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to skyper
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.