Modify

Opened 8 months ago

Closed 7 months ago

Last modified 5 weeks ago

#18985 closed defect (fixed)

Changeset Manager: Strange behaviour when downloading a deleted object

Reported by: skyper Owned by: team
Priority: normal Milestone: 20.05
Component: Core Version:
Keywords: template_report changeset manager download deleted Cc: GerdP

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Have a changeset with a delete node in changeset manager
  2. In changeset content tab sort clicking on first column header
  3. Select the deleted node a click on download selected object

What is the expected result?

A warning that the deleted object can not be downloaded

What happens instead?

Lots of objects are downloaded

Please provide any additional information below. Attach a screenshot if possible.

Not sure if #18566 is involved here

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-03-24 07:37:08 +0100 (Tue, 24 Mar 2020)
Revision:16200
Build-Date:2020-03-25 02:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- W: Nothing to select - <html>The selected object is not available in the current<br>edit layer 'Data Layer 3'.</html>

Attachments (0)

Change History (12)

comment:1 Changed 8 months ago by skyper

Cc: GerdP added

comment:2 Changed 8 months ago by GerdP

Can't reproduce. There is no button "download selected object" but one with tool tip "Download the current version of the selected objects". When I click that I see the expected warning. OTOH I also see that JOSM tries to download the parents of the deleted node which looks wrong.
Maybe you used the right click option "Download objects"? This seems to have the same meaning, it also produces the warning.

comment:3 Changed 8 months ago by GerdP

Just a moment: It seems that the selection of the object doesn't work. When I download the history for a selected node object I get one for another object in the list.

comment:4 Changed 8 months ago by GerdP

Tested version r15937 still works OK. Must be a regression from a recent change.

Last edited 8 months ago by GerdP (previous) (diff)

comment:5 in reply to:  3 Changed 8 months ago by skyper

The selection does not work if you sort the list. Until that everything is Ok. Regression of r16121

invalid or duplicate of #18919?

comment:6 Changed 8 months ago by skyper

Description: modified (diff)

comment:7 Changed 8 months ago by GerdP

I did not sort intentionally but I cannot reproduce without sorting. I'll investigate the unexpected downloading of parents tomorrow.

comment:8 in reply to:  7 Changed 8 months ago by GerdP

Replying to GerdP:

I'll investigate the unexpected downloading of parents tomorrow.

That seems to be intended- See r11091. DownloadPrimitivesWithReferrersTask is executed with downloadReferrers set to true, also the members of relations are downloaded because full is also set to true.
Maybe it would be better to open the "download object" dialog filled with the selected objects so that a user can decide wether parents / children are wanted or not.
I'll try to add code so that DownloadPrimitivesWithReferrersTask doesn't try to download parents or children of deleted objects.

comment:9 Changed 8 months ago by GerdP

In 16203/josm:

see #18985: avoid to download parents of deleted (invisble) objects

  • filter invisible objects before starting DownloadReferrersTask
  • don't show "retrying with an individual request for each object" for a rc 404 when only one object was requested

comment:10 Changed 7 months ago by GerdP

Milestone: 20.04
Resolution: fixed
Status: newclosed

I think the problems mentioned in this ticket are solved.

comment:11 Changed 7 months ago by Klumbumbus

Milestone: 20.0420.05

Milestone renamed

comment:12 Changed 5 weeks ago by skyper

see #19984.

Last edited 5 weeks ago by skyper (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.