Modify

#18618 closed defect (duplicate)

JOSM throws error on startup, continues to show splash screen but does not proceed to edit window

Reported by: wolfgang@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. start josm from command line

What is the expected result?

JOSM starting, showing splash screen during init phase, then proceed to edit window

What happens instead?

JOSM starting, showing splash screen during init phase, opens error window while splash screen continues to be shown, never proceeds to showing edit window. Message from error window shown below.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Build-Date:2020-01-02 21:52:31
Revision:15628
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15628 de) FreeBSD
Memory Usage: 316 MB / 912 MB (177 MB allocated, but free)
Java version: 1.8.0_242-b07, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1

Last errors/warnings:
- E: Handled by bug report queue: java.lang.UnsatisfiedLinkError: sun.nio.fs.LinuxWatchService.inotifyInit()I


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.UnsatisfiedLinkError: sun.nio.fs.LinuxWatchService.inotifyInit()I
	at sun.nio.fs.LinuxWatchService.inotifyInit(Native Method)
	at sun.nio.fs.LinuxWatchService.<init>(LinuxWatchService.java:59)
	at sun.nio.fs.BsdFileSystem.newWatchService(BsdFileSystem.java:51)
	at org.openstreetmap.josm.io.FileWatcher.<init>(FileWatcher.java:55)
	at org.openstreetmap.josm.io.FileWatcher$InstanceHolder.<clinit>(FileWatcher.java:38)
	at org.openstreetmap.josm.io.FileWatcher.getDefaultInstance(FileWatcher.java:47)
	at org.openstreetmap.josm.gui.MainInitialization.beforeInitializationTasks(MainInitialization.java:72)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:71)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:903)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)

Attachments (0)

Change History (1)

comment:1 Changed 13 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18583.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.